I am using Ubuntu 12.04, and am trying to use NIS with AutoFS to mount the NFS shares I have access to for projects. I can mount my networked home directory, which is used for the remote terminals, but this is owned by my user. Project directories I allocate are owned by root, but are in a group I am in, and on the remote terminals, configured by IT, I am able to mount those with autoFS too (simply by naviagting to their directory). I get access denied when I run automount in the foreground.

Here is where I believe the issue is: I have been working on getting PAM with Kerberos working to log into the network user, but have not yet suceeded. So I am using a local user with the same name, UID, and GID as the NIS user. When I check its group membership using id, my local user says it is in the group that owns the project directory, which is not in my local /etc/group file. I was led to believe I could automount these directories without logging in to the network user, if I chose not to install kerberos.

All of this would be a great question for corporate IT, except they do not support Ubuntu 12.04 officially. They encourage using it, but I don't have high hopes that they will give me any support for anything except the RHEL and 10.04 images that they distribute pre configured.

Edit: I noticed that the directories I can mount have rwxrwxr-x permissions, whereas the one I cannot has rwxrwx--- permissions. So when my local root goes to mount it it does not have permission, I would guess. But I do not believe it is possible to run automount as my user, which has permissions for that directory.

migrated from superuser.com Jul 3 '12 at 23:01

This question came from our site for computer enthusiasts and power users.

  • Tricky one. Have you tried creating a group on your local machine with the same gid and name as the one that owns the project directory? Can you get hold of all the config files that your corporate IT distribute with their pre-configured 10.04 image? – Ladadadada Jul 7 '12 at 8:50
  • I tried adding my local root user to the network group, and to a local group with the same GID and name, but there may be something tricky going on there. Everything is based on GID, right? Because there is no NIS group with the name that owns the directory, however there are many with the same GID and a similar name. (Just extra characters appended) There may be some group size issue that they are dealing with? In either case I asked someone about it, and what they can do is give me a a static IP and change the permissions just for users from that IP. – uxp100 Jul 9 '12 at 17:22

As indicated in comments I asked someone about it, and what they do is assign a static IP to my MAC and change the permissions just for users from that IP, or something similar. I wasn't told all the details, but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.