I'm trying to download the http://code.opencv.org/svn/opencv/trunk/ repository of all of the OpenCV source code - as specified in an OpenCV installation tutorial.

In the tutorial, the repository https://code.ros.org/svn/opencv/trunk/ is used, but they moved it to http://code.opencv.org/svn/opencv/trunk/, and now you need a password to access the code.ros.org repository.

Anyway, I'm using TortoiseSVN to download the SVN repository. (I get the same error with http://sourceforge.net/projects/win32svn/) I get this:

Checkout from http://code.opencv.org/svn/opencv/trunk, revision HEAD, Fully recursive, Externals included

Server sent unexpected return value (400 Bad request. Method Unknown) in response to REPORT request for '/svn/opencv/!svn/vcc/default'

On the TortoiseSVN site I found something about this 400 error:

You're behind a firewall which blocks DAV requests. Most firewalls do that. Either ask your Administrator to change the firewall, or access the repository with https:// instead of http:// like in https://svn.collab.net/repos/svn/ That way you connect to the repository with SSL encryption, which firewalls can't interfere with (if they don't block the SSL port completely). Also some virus scanners (i.e. Kapersky) are known to interfere and cause this error.

The code.ros.org repository is https://, so I would be able to access it, but I need a password, so I can't.

I made an account on ros.org, but it seems that I still need a password (which I don't know) to access the code repository. My username-password combination does not work.

I unblocked all of the TortoiseSVN programs in my firewall settings. Nothing changed.

I temporarily stopped my firewall to see if it was interfering with my request. I got the same error.

How can I do an svn checkout http://code.opencv.org/svn/opencv/trunk/opencv/ so that I don't get this error? Is there any way to make it https://?

Any help would be appreciated!

  • I just manually migrated it to Serverfault.com. – eboix Jun 21 '12 at 13:32

Yay! I tried it on a different network and it worked!

No idea why it didn't work in the beginning, though :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.