I have been following the directions here:


And ran into a problem where my System DSN is not showing up as a ODBC provider.

I found this which seemed promising:


I was not able to delete the key but followed but I did what was suggested:

"If unable to delete the key, double-click the key and erase the Data value entered. Once done, the value should read ' (value not set) '"

However, after following the instructions my System DSN still does not appear as an option.

The USER DSN however does show...has shown but does not work as I get a permissions error.

Any ideas?

1 Answer 1


Have you verified you're not using a 32-bit driver on a 64-bit OS?


32 = C:\Windows\SysWOW64\odbcad32.exe   64 = C:\Windows\System32\odbcad32.exe

  • Go Tech! (Atlanta Native) I have tried both 32 and 64 separately and also installed alongside each other. I am definitely using the 64 bit driver on a 64 bit machine assuming. However I started testing with the 32 bit when I read that BIDS didnt support the 64 bit drivers and was thinking that may be my issue as well. Jul 8, 2012 at 3:06
  • yeah...there is an odbcad32.exe file in each of the folders mentioned. For what I am trying to do (sync a MSSQL view with MySQL) ODBC the best choice? Should I be looking at the .net drive for mysql instead? Also...maybe the problem is that even after uninstalling both drivers the files you mentioned are still there...maybe a conflict? Jul 8, 2012 at 3:27
  • Where I am even more confused is that the User DSN shows in the ODBC selection list...however, it won't connect. Gives yet another error even though connect test is successful when setting up the User DSN. Jul 8, 2012 at 6:51
  • @user1114330. If the connection test is working in the DSN settings area, that's a good first step... Make sure your DSN names are unique... I name mine like "system-DSN-32" and "system-DSN-64" to differentiate them. My 32-bit apps need to use the 32-bit DSN and similar for 64-bit apps Jul 8, 2012 at 12:11
  • @BrianAdkins...right, at least some progress has been made. Definitely named them uniquely. My problem now is that I tried to create a DSN using the odbcad32.exe that is in the SysWOW64 folder...it first tells me I do not have permissions (my account has admin rights). I read to ignore and try creating the DSN anyway...only problem the MySQL ODBC drivers are not in the list of options? Jul 9, 2012 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .