I read:

But could not fix it: suddenly (after a year of service, no changes on my winscp settings) it gives me "network error connection timed out" (im using ec2-user) (also from the amazon console).

  • Log FILE: http://pastebin.com/vNq6YQvN
  • All Sites that run on it run fine
  • port 22 is allowed (never changed it) (security group)
  • using the correct ec2-user and domain
  • via my winscp / putty i can connect to other hosting (via ssh)

update: SOLVED. I spend 2 days without looking at my own IP address .... (since it did not change the past 3 years....). Your comments made the spark in my brain. thank you so much. (and only now i find dozens of discussions from angry users that the static addresses from my provider are changed to dynamic ones: http://gathering.tweakers.net/forum/list_messages/1501005/12 ...)

  • Your post is > 30K character limit and I suspect that some of the information you tried to post has been truncated. Please review your question and attempt to whittle it dow to relvant information. – user9517 Jul 9 '12 at 20:32
  • A service such as fpaste.org / pastebin will help here I suspect sshd has not started, but I can't tell as the information provided appears truncated, per Iains comment. – Oneiroi Jul 9 '12 at 20:34
  • updated the logs (made a pastebin account), thanks – edelwater Jul 9 '12 at 20:48

I think your logs are snipped.

Here are the things you need to check

Check if the name you are connecting to is correct. It may have changed and we have no idea about you setup/

Check the security group of the EC2 instance , is SSH allowed by firewall? What about IP

Check in your log files if it copied the SSH Public Key

| improve this answer | |
  • "what about IP" made the spark – edelwater Jul 9 '12 at 20:59
  • 2
    hah :D so you have the all-spark – Abhishek Dujari Jul 9 '12 at 21:28
  • 2
    im glad there are primes – edelwater Jul 9 '12 at 21:35
  • Something similar happened to me before when rebooting an instance. The Elastic IP was disassociated with the server. – David Csonka Jul 10 '12 at 1:14
  • @David, yeah that happens. I know it happens when you stop the instance. Now with multipe IPs to EC2 this is gonna be one hell of a headache. – Abhishek Dujari Jul 10 '12 at 8:05

If it's connection timed out, then it's the problem on the firewall. Check with your desktop, ISP, and home/company firewall, GPO policy, as well the EC2 firewall. Eventually delete and remove each rule so hopefully you will get thru. It clearly says that the sshd is started.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.