We have 3 Windows 2003 domain controllers each is a DNS server. We are set up to use single label domain names; the Registry settings per Microsoft have been made to the domain controllers / DNS servers to support single label names. This setup has been working fine for quite some time. Noticed last week though that clients are no longer registering in DNS forward lookup zones, they do however register in the reverse lookup.

Event ID:  11165

The system failed to register host (A) resource records (RRs) for network adapter
with settings:

   Adapter Name : {73DA8960-B5E6-46FC-9EC1-8FEA7A799EB2}
   Host Name : workstation5
   Primary Domain Suffix : PDC1
   DNS server list :,
   Sent update to server : <?>
   IP Address(es) :

 The reason the system could not register these RRs was because the DNS
server contacted refused the update request. The reasons for this might be (a)
you are not allowed to update the specified DNS domain name, or (b) because the
DNS server authoritative for this name does not support the DNS dynamic update

 To register the DNS host (A) resource records using the specific DNS
domain name and IP addresses for this adapter, contact your DNS server or
network systems administrator.

You mention the registry settings on the DC's but did you update the clients as well?


See the full section on How to enable Windows-based clients to perform dynamic updates to single-label DNS zones inside that KB article linked.

Check the problematic clients for those settings.

| improve this answer | |
  • Thanks for the reply. We never had to make any changes to our client machines in order to register with DNS. We have had our DNS servers for several years and they have been working fine up until now. – Matt Fitz Jul 10 '12 at 20:20
  • Welcome...Why it worked until now is a mystery, since by design it shouldn't send dynamic updates without changes to all the clients. – TheCleaner Jul 10 '12 at 20:40
  • Changed a couple of clients that were not registering in DNS per the article that your sent, now the clients are registering. Thanks very much for your help. I am still not sure why it worked before. I guess that it could have been a bug that allowed it to work then was fixed by a Windows update. – Matt Fitz Jul 10 '12 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.