Let me try to explain.

One week ago I've installed a new Server 2008 R2 server with the intention to make it a mailserver. On the server I installed Exchange 2010.

For one week all services where working. (inbound/outbound mail, Outlook webaccess, internal mail in the company domain)

Since yesterday after updating and restarting my server (not sure if its relevant but its info) a strange thing is happing to the Inbound SMTP mail. (for the record all other mail operations are working)

Things I've done to debug:

When I run the Inbound smtp mail check on: test exchange connectivity I get exception:

The server returned status code 421 - Service not available, closing transmission channel. The server response was: 4.4.1 Connection timed out Exception details: Message: Service not available, closing transmission channel. The server response was: 4.4.1 Connection timed out Type: System.Net.Mail.SmtpException Stack trace: at System.Net.Mail.SmtpConnection.GetConnection(ServicePoint servicePoint) at System.Net.Mail.SmtpClient.Send(MailMessage message) at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()

When I telnet from the following locations: pc in my domain, On the mailserver itself, and a pc outside of the domain I get the exact same behaviour. I telnet to : telnet mail.mydomain.com 25 telnet gives me an answer. Then I say helo: helo mydomain.com And the answer is: 421 4.4.1 Connection timed out Connection to host is lost

But now the REALY weird part. If I leave my server alone then after a few hours Inbound SMTP mail STARTS working again???!!! And from that moment on it stays working UNTIL I reboot my server again...

The time when the service starts answering smtp calls again is totaly random of course and is leaving me with my hands in my hair how on earth I'm going to debug this problem. I've googled and tried stuff for hours now so I'm desperate for more ideas how to troubleshoot this. :)

Extra info:

The server is not busy at all it has CPU 0% and 1,7GB memory allocated... so its doing nothing

Does anybody have point for me to investigate this weird problem?

Aditional info:

I noticed that I had quite a few warnings in the application log related to exchange and 1 error. All of those warnings are now fixed by setting some exchange services to delayed start. Looked like the Exchange system was starting to fast.

After this I rebooted a few times again but unfortunately fixing the warnings did not fix the time out problem.

More info:

As a test I recreated the following connectors while rebooting between every recreation to test if this might help:

Receive connector (organisation hub) Default client connector for non-MAPI (server config hub) Default hub connector also configured for internet access (server config hub) Unfortunatly these actions also did not help....

  • The server is only an Exchange server? not a Domain Controller for instance? – Mathias R. Jessen Jul 13 '12 at 0:16
  • Hi Mathias this is a dedicated Exchange server – Joost Verdaasdonk Jul 13 '12 at 8:34

I finally tracked down the cause of the time-outs.

The problem was in the MS Exchange Transport service itself. When I was receiving the time-out again I got the bright idea to manually restart the service. And immediately after the restart the SMTP inbound was working and telnet could say HELO again.

To reproduce I restarted server and there was my time-out again... then restart service and yep stuff is up again.

As a test I decided to change the start-up property of the transport service from manual to manual (delayed) and restarted the server again... and what do you know all the gizmo's in the box start working normal again and inbound was working after a restart.

ofc I tested this whit 10 reboots but all is working again. What the root-cause of this problem is will remain a mystery but the work-around will do for now.

I will monitor the behaviour of the box more closely now. And I hope this will help somebody else pulling his hair out over this problem! :)

  • Restarting the Microsoft Transport service did the trick for me. I was able to telnet to the exchange server but as soon as I attempted anything it timed out and dropped the connection. I restarted the transport service and was then able to telnet. Emails then started to flow. Thank you! – user141593 Oct 18 '12 at 6:38
  • Hi Bela, your welcome. – Joost Verdaasdonk Oct 18 '12 at 11:52
  • Joost, you saved my life because I had the same problem today. So, I'm your main fan from now on ;-)) My Exchange Server is a virtual machine, and the problem appeared when a made some CPU tests, and decided to add vCPU and vRAM to improve performance. It seems to be related to incongruence between the hardware "presented" to the VM amb the information in the registry, and that makes transport service malfunction. You said that tou had the problem after an update of the machine ..... any new hardware? Anyway, thanks to your post we solved the problem!!!! Tank you, thank you , tank you!! – user141843 Oct 19 '12 at 14:48
  • Hi Francesc, glad it solved the issue for you too! ;-) what I remember is that it happended after à win update... But at that time I also updated RAM from 8 to 12 GB. So who knows perhaps that was my trigger too. The good news is that this problem never came back too so lets hope it remains that way! And your welcome ofc. :) – Joost Verdaasdonk Oct 19 '12 at 15:54

For ERROR: 'CONNECT' caused '421 Service not available, closing transmission channel', check if your connection IP is blocked by recipient mail gateway server.

You can telnet from different locations to verify this issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.