My server hosts several sites. All of them are fine except for one with a subdomain.domain.com/ip binding. Attempting to access it just times out. When attempting to access it via the ip I would expect to simple get the IIS 7 log page, but that also times out. When access from the server, the site works just fine.

I've had this come up previously and a restart fixed it, but I can't restart that machine during the work day. I tried restarting just IIS, but no change. Any thoughts?


So the issue turned out to be that the subnet mask for the site was being changed from to It reoccurred several times and would often affect multiple ip addresses. At one point, all of them changed. We kept resetting to the correct subnet mask when this occurred and it now appears to have stopped the behavior. However, I don't know what would have cause this to happen in the first place.


Some things to check:

  1. Is the server listening on the IP in question?
  2. Does a DNS query correctly resolve to the IP?
  3. Is there a firewall blocking that IP?
  4. Can you ping that IP from separate nodes both within and outside the network?
  • I'm a bit of a noob with this stuff, but 1. Yes. If that means going into the network connection IPv4 properties and verify that it's in the list of IP addresses. 2. Yes. 3. Not that I can see. I've never created one and it was working yesterday. 4. I don't have access to any other machine on my servers local network, but I can ping the ip address from the machine itself. I cannot from my computer. – EricG Jul 12 '12 at 17:32
  • Oh geezz. It appears to have "fixed itself" if that offers any insites for future prevention. – EricG Jul 12 '12 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.