I am currently doing some development work and need to test it on a server platform before installing into onto the production server, for obvious reasons.

The other day I successfully installed OpenSuse 12.1 on Vmware Workstation 8 host machine on Windows 7 x64. After the install it was working successfully, connected to the network, I set the network card static and all was fine, could happily talk to other devices on my network.

I shutdown it down then shutdown the host PC at night and today when I booted it up it can no longer connect to the network.

I've gone into Yast and put it back to DHCP and it is unable to get an address.

I've tried setting it static to a different address with no luck.

I've also tried running /etc/init.d/network restart and has made no difference I've also tried ifconfig eth0 down followed by ``ifconfig eth0 up` and also no luck.

I've looked at ifconfig and it appears to be getting the wrong address, I think it has kept a cache from when I tried using the NAT network card in my desperate attempt to try and get it working.

I've looked arp -n and it shows the wrong this wrong address ( I've tried deleting this arp entry using arp -d -i eth0 but it won't go away.

I've tried rebooting and no difference.

Screenshot of /var/log/messages

I've attached a screenshot of the /var/log/messages file about the network card.

When I set the IP address static I used

Default Gateway:

I retrieved these details (except the IP Address) from running ipconfig /all on my Windows host machine to ensure they are correct.

When I set the network card static with the above details I get

Reply from Destination Host Unreachable

Thanks for any help you can provide


The arp deletion did remove the entry, didn't realise you had to wait 20 seconds for it to clear.

Now when I run ifconfig with DHCP being used I get the following

eth0 Link encap:Ethernet hWAddr 00:0C:29:8E:35:7B
RX packets: 31 errors:0 dropped: 0 overruns: 0 frame: 0
TX packets: 48 errors: 0 dropped: 0 overruns: 0 carrier: 0
collions: 0 txqueuelen:1000
RX bytes:8154 (7.9 kb) TX bytes:12036 (11.7kb)
Interrupt:19 Base address:0x2000

By some miracle I managed to find the problem.

There appears to be a bug in Vmware Workstation 8 that makes the virtual machine, even though it had a bridged network connection, try and use one of the vmnet network adapters that get installed for when the vm's network is using NAT.

I went into the adapter settings on the host machine and disabled the vmnet network adapters and restarted the vm and when it came up it immediately did what it should have network wise and communicated with everything on my network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.