0

Yikes. I just attempted to enable cache and mem_cache using sudo a2enmod mem_cache and sudo a2enmod cache on my Ubuntu lucid server. Now my apache2 server doesn't respond at all. I tried sudo a2dismod cache and sudo a2dismod mem_cache but now apache does not respond. Tried restarting apache2 and rebooting, but no dice.

sudo apache2ctl fullstatus gives me:

w3m: Can't load http://localhost:80/server-status

Help! What else does a2enmod change that I can revert back?

  • 1
    Anything out of the apache error log? – Mike Purcell Jul 13 '12 at 20:52
1

Don't use it. They have removed it from Apache HTTPD 2.4. There's no much point in getting an obsolete feature to work.

0

Check the actual Apache configuration file, located usually at /etc/httpd/conf/httpd.conf or /etc/apache2/httpd.conf and check under the Dynamic Shared Object (DSO) Support section, to make sure everything is kosher.

Make sure the paths are correct, etc.

E.g.

LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so

*You may also want to check the mod_cache documentation on Apache's site.*

0

After saving my configuration files in /etc/apache2/sites-available, I ended up just purging and reinstalling everything apache using the instructions here. Then I copied back the configuration files, re-enabled my sites and any needed plugins, and restarted apache2. I still don't have memcache working, and I don't know what the problem was, but I'll just wait on attempting to get memcache working as it's not essential for me now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.