2

I'm trying to access a SQL Server 2012 database from a SQL Server Management Studio 2008 from a remote machine(on the same LAN). I can connect to the database using "sa" user under "SERVER_NAME\INSTANCE" on the local SQL Server Management Studio 2012, but I can't connect remotelly with "sa" even using "SERVER_NAME\INSTANCE", only "SERVER_NAME" or with the server IP address using the SQL Server Management Studio 2008. Already disabled firewall and made proper settings to connect with sa, am I missing some point?

5

Make sure that you have enabled TCP/IP for the SQL Server. Check also the port setting.

The full step by step guide for enabling is here

SQL Browser Service is only needed if you have more instances on one server. See here and here for some more information.

  • Turning on TCP/IP solved it for me. – johnny Jul 14 '15 at 19:53
1

Enable the SQL Browser Service on the server

You also need to make sure the firewall is open on the server on ports 1433 and 1434.

You can reference this identical question: SQL 2008 R2 Named Instance Client Connectivity Issues?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.