2

I have a Samba shared folder on an Ubuntu box which I can access from my Windows 7 PC and within which, as a non-administrator Windows user, can create and update files and folders.

However, when I create a symlink in Windows to this folder using mklink /d I find that all the folders in that share have a padlock Symbol on them in Windows Explorer, and when I right-click within those folders and click "New", the only option is "Folder" with an administrator-shield symbol next to it, rather than the normal file types I can create. I can go to the Security settings for any of folders within the symlink and give Modify permissions to "Everyone" which removes the padlock symbol and then allows me to right-click and create other file types, but I have to do this for every folder individually, and any new folders that are created get the padlock symbol and restricted file-type list.

I want the symlink to behave exactly the same as when I access the share directly. Is this possible?

I don't get the same problem when creating a symlink to a shared folder from another Windows box or another folder on the same PC.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.