I've set up a git server using instructions from Scott Chacon's ProGit book. I can connect, and interact with the repositories that I've set up with no problems using Git Bash or Git GUI from msysgit with no problems. I'm running git on a VM under Virtualbox on my machine, with ssh being port forwarded.

However, when I try to access the repository using either SmartGit or Teamcity, I get error messages that say that the remote end hung up unexpectedly.

I'm using an ssh key for authentication and it seems to work with Git Bash and GUI as I'm asked for the passphrase that links to those but I'm not sure why it doesn't work with teamcity (which is also running on my machine).

The URL that I'm using to connect to git is ssh://git@3439vsweb/home/git/readme.git

This URL works (as I've said before) with Git Bash and Gui so I can't figure out any reason why it wouldn't work with teamcity.

  • Are your ssh key files located in C:\Users\Piers\.ssh ? I think this is where SmartGit looks for them. – Kenny Rasschaert Jul 16 '12 at 9:11
  • I've just copied them there, but that didn't help. – Piers Karsenbarg Jul 16 '12 at 9:18
  • Presumably because teamcity isn't using your key. Fix that and all will be well. – womble Jul 16 '12 at 9:18
  • I have done. I've copied two keys (mine and one I set up for teamcity) to a location that it can get to on the hard drive. I'm running teamcity under my user and have tried both with my key and the other one. Neither work. – Piers Karsenbarg Jul 16 '12 at 9:20

It seems some of the software I was using didn't like the computer name. I tried it with the IP of the computer I was using and it all worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.