i am encountering a very strange error on the my tfs server. I have a server on which i'm hosting the tfs instance and a server in witch i'm hosting the sql backend for the tfs. The thing is that i want to move the sql instance on another server, a task which i have done once before, and for some reason the tfs server doesn't want to cooperate.

The actions i have undertaken till now are: i've installed sql server 2012 on the my new server, i have moved the databases to the new server(backup - restore), and bow i'm trying to make the chance in the tfs administrative console and for some reason it doesn't work. I have stopped iis iisreset \stop, i have stoped the tfs net stop TfsAgentJob and when i try to run 'tfsconfig prepsql /sqlinstance:servername' or tfsconfig prepsql /sqlinstance:servername\instancename it gives me the following error:

CreateTfsExecRole.sql Block #1 Error: TF246017: Team Foundation Server could not connect to the database. Verify that the server that is hosting the database is operational, and that network problems are not blocking communication with the server..

The thing is that the network shouldn't be the problem. I can ping the new sql server from the tfs server and i can connect to the sql server from other servers and i just don't understand the error. I have also tried to the command with the firewall disabled and still the same result. I's there something new in sql 2012 that has to be configured in order for this to work ?

  • When you say you're able to connect to the SQL server from other servers, do you mean via Management Studio? Is the SQL instance the default instance or a named one? – Chris McKeown Jul 16 '12 at 19:37
  • @Chris Yes i connected via Management Studio form other SQL servers and it worked just fine. The new SQL instance is the default instance. – primero Jul 16 '12 at 20:36
  • Is it running on the default port? Can you telnet to that port from the TFS server? – Chris McKeown Jul 16 '12 at 20:55
  • Yes it is running on 1433 and I tested with telnet and it worked. Also I changed to 1434 and tried because I read someware that it worked on that specific port but sadly I got the same result. – primero Jul 16 '12 at 21:04
  • Weird. I wonder if the error is misleading and it could be a rights issue? Does the account that you're running the command as have sysadmin rights on the instance? I suspect you're going to say yes but I thought I'd ask anyway :-) – Chris McKeown Jul 16 '12 at 21:09

I wonder if the error is misleading and it could be a rights issue? Ensure that the account you're running the tfsconfig command as has sysadmin rights on the SQL instance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.