2

I'm currently setting up amavis and spamassassin with postfix. So far SpamAssassin blocks and bounces Spam. If I set $final_spam_destiny to D_PASS the mail gets through, but the $sa_spam_subject_tag does not get attached and the X-Spam value does not exist either.

The log clearly states, that it passes Spam:

amavis[28391]: (28391-01) Passed SPAM, [209.***] [93.1***] <s**g@*.com> -> <*@s*.de>, quarantine: C/spam-CJpo9ylrA1wv.gz, Message-ID: <5006FC18.5090100@*.com>, mail_id: CJpo9ylrA1wv, Hits: 999.201, size: 2125, queued_as: 37D3C3148077, 4803 ms

Message header contains:

Return-Path: <*@*.com>
X-Original-To: *@*.de
Delivered-To: *@*.de
Received: from localhost (localhost.localdomain [127.0.0.1])
    by *.de (Postfix) with ESMTP id 37D3C3148077
    for <*@*.de>; Wed, 18 Jul 2012 20:10:43 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at *.de
Received: from *.de ([127.0.0.1])
    by localhost (*.de [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id CJpo9ylrA1wv for <*@*.de>;
    Wed, 18 Jul 2012 20:10:38 +0200 (CEST)
Received-SPF: pass ...
Received: from mail-bk0-f53.google.com (mail-bk0-f53.google.com [209.85.214.53])...
Received: by bkwj4 with SMTP id j4so1701207bkw.40...
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    d=gmail.com; s=20120113;
    h=message-id:date:from:user-agent:mime-version:to:subject
     :content-type:content-transfer-encoding;
    bh=id84uDPa9SMZAVd+g2pYg3Hl9aPfnapoGlOygxrIuV4=;
    b=JIl4ACvkBlszuucl5FcvhGLv3zJxmxxcwXNrEfdow5hhzkxPdYuyiZ+l6ONNNYpQ/g
     S1rzFxK13JZ8meekXFZMjA6e+vDlngLjHgBqpT8lmYVAoc+XBsZQZmtVgchIRgVTckZ7
     yCoYKcR0uC4OW9PWZnCmM5gCnz/EUp/YpOZ/6cSRkZQCFoFyzdsMinC4vZObwvSviTlZ
     0Yg3NricaELpWH9umginV0rBH3XQzfVadkbfZFfmr2ZIt/bhVl1Gg9MR5rZ1hFcSotm+
     7JmpqetIoTRCr3lK41ePY26VbVf9doM3GczWrjZuG1jzv8xyUMKXs2SRQuWaM2X0CB7R
     +X9Q==
Received: by 10.205.123.9 with SMTP id gi9mr2278388bkc.50.1342635037852;
    Wed, 18 Jul 2012 11:10:37 -0700 (PDT)
Received: from [192.168.1.68] (srbk-5d801d46.pool.mediaWays.net. [93.128.29.70])
    by mx.google.com with ESMTPS id t23sm12424175bks.4.2012.07.18.11.10.35
    (version=SSLv3 cipher=OTHER);
    Wed, 18 Jul 2012 11:10:37 -0700 (PDT)
Message-ID: <*.*@gmail.com>

This happens only on my second domain. On the first domain Spamassassin works as expected.

Any help?

2

I got it:

i added my second domain in the amavis/conf.d/05-domain-id file:

@local_domains_acl = ( ".$mydomain",".seconddomain.de" );

now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.