I'm not sure what I did, but I've somehow got Cygwin installed in such a way that even when I try to run an ordinary windows shell, Cygwin is interfering. I have batch scripts that I want to run in the default windows way that Cygwin complains about. I can't change them; I need to run them in the felaut shell. Is there any way to get my cmd shell back without completely uninstalling cygwin?

I did try renaming cygwin1.dll to something else, and the shell seems to work just fine until foo.bat tries to run the exe. Then I get a complaint that cygwin1.dll has moved, so it looks like cygwin is being invoked by the windows shell? I have the typical windows prompt in the cmd shell. I've even tried the powershell with the same results.

Interestingly, if I run the batch file directly from Win-R, using cmd /c, it works. So I'm pretty confused.

  • I've now removed it from the path all together, and as expected, that works, but I can't invoke cygwin, obviously. (Well, I can, but I have to navigate to the cygwin directly manually and invoke bash from there.) Jul 19 '12 at 15:13

move the Cygwin path entry to the end of the path statement.

  • It is, and always has been. Still have the problem. Jul 19 '12 at 14:28
  • I had the cywin path in my path statement twice once, not sure how but I removed the one at the end not noticing the 1st entry.. probably not the issue here but...
    – tony roth
    Jul 19 '12 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.