I'm trying to debug a Cisco ASA 5505 that I do not have physical access to. I am using GoToMeeting to control a techs computer to talk to the router.

Here is a picture of the router output right after it's been rebooted: http://i1256.photobucket.com/albums/ii488/joshschmelzle/puttyissue.png

The speed has not been changed in the router config. The serial setting wasn't changed. When I connect with PuTTY after it's been rebooted. I just see a cursor and when I type anything it stays on the same line even if I hit Enter.

I tested this router on my Windows 7 machine at my desk before I sent it to the customer and it worked fine.

Here are the COM1 settings: Bits per sec: 9600 Data bits: 8 Parity: none Stop bits: 1 Flow control: none

I tried removing and installing the COM1 drivers on the remote machine, and having someone unplug power and plug it back in several times. I think this is a baud rate issue, but i'm not sure.

  • 1
    Pretty sure the baud rate on an ASA is 9600 by default. I'll plug mine in and see if it can't be changed. If someone bothered to change is they probably went with 28800 or 115200, try those and see what you get. Jul 19, 2012 at 15:42
  • Depending on your computer's hardware (the exact type of serial port you've got) Putty might not be able to set the baud correctly. Check the setting in Device Manager as well, make sure they match.
    – Chris S
    Jul 19, 2012 at 16:32

2 Answers 2


That looks exactly like baud rate mismatch should. It's possible that somebody changed the default baud rate on the ASA from 9600 to something else. Try 115200 N81, 38400 N81, and 19200 N81 and see how they act.


It ended up being a faulty serial cable not a baud rate issue. IT swapped it out for me today.

  • Hmm... looked like baud barf to me but glad you got it sorted out. Jul 20, 2012 at 20:26
  • When the tech returns next week I'll try to duplicate it with the faulty serial cable to verify.
    – jsz
    Jul 20, 2012 at 20:57
  • I didn't mean to imply you weren't right... >smile< That's just what baud barf looks like, too. A faulty serial cable definitely would be my second choice of root cause (because RS-232 is a pretty beefy signaling standard) after ruling out a baud rate mismatch. Jul 20, 2012 at 21:03
  • Well, the tech didn't bring the cable back so I won't be able to duplicate it. :( Thanks everyone.
    – jsz
    Jul 31, 2012 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.