I am having trouble getting NFS setup on with vagrant:

On my local machine I have installed NFS:

apt-get install nfs-common nfs-kernel-server

And in my Vagrantfile set it to be used:

config.vm.share_folder("v-root", "/vagrant", ".", :nfs => true)

On vagrant up I get:

exportfs: /home/<user>/path/to/dir does not support NFS export

Mounting NFS shared folders failed. This is most often caused by the NFS
client software not being installed on the guest machine. Please verify
that the NFS client software is properly installed, and consult any resources
specific to the linux distro you're using for more information on how to
do this.

Am I missing a step or two here?

I'm aware of some issues with ubuntus encrypted home folders and NFS but I understand this is only meant to be a problem before boot.

[update] my /etc/exports file looks like this:

# VAGRANT-BEGIN: 5af3e5d6-b086-416d-8eab-987275445634
# VAGRANT-END: 5af3e5d6-b086-416d-8eab-987275445634
  • Does the machine on which you're working have the NFS client software as well? Is nfs-common (not just nfs-kernel-server) installed?
    – mpez0
    Jul 23, 2012 at 15:18
  • Yes nfs-common is also installed
    – user71736
    Jul 23, 2012 at 15:19

3 Answers 3


Actually is not possibile to export anything via NFS inside an ecryptfs volume. exportfs: Warning: /home/user/share does not support NFS export


I will assume the "<" and ">" in your exports file is for example only... if not remove it.


Why not first try to export /home and see if that works?

  • My setup works well when not in the home directory.
    – user71736
    Jul 25, 2012 at 22:46
  • Not sure if it matters much, but how is your /home mounted, which filesystem, and is /home a symlink?
    – aseq
    Jul 26, 2012 at 19:50
  • I'm not sure - whatever defaults on ubuntu 12.04?
    – user71736
    Jul 27, 2012 at 8:51

try to install or configure idmapd daemon on client and server. That will link remote and local users. Then you need to install nfs-common on client side, this provides nfs mount option.

You must log in to answer this question.