I cloned one hard drive to another and things are working well. Except for my NTFS volume not taking up the entire partition (due to the older volume being smaller).

Doing this:

sudo ntfsresize -x /dev/sdb3

I get this error:

ERROR: Could not get the old volume parameters from the backup bootsector

How do I fix this?

  • Also, I can patch things up on a windows machine if that is easier. – UsAaR33 Jul 23 '12 at 19:50
  • It's now March 2013, did you find a fix for this? – pauldoo Mar 3 '13 at 16:31

In reply to Luciano (StackExchange wouldn't allow me to comment, so I must put this in an own anser) - I had the same problem today and will write here the exact steps for testdisk...

  • Choose disk (/dev/sda in my case)
  • Choose Intel
  • Choose Advanced
  • Choose with up/down arrows the correct partition and with left/right arrows the Option [Boot]
  • Choose [Rebuild BS]
  • Testdisk complains that "Extrapolated boot sector and current boot sector are different." - Choose [Write]
  • Confirm with Y and Quit

[Edit] After reboot into Windows-Recovery using "starting-help" (or whatever it is called in English), it said something like "Disk is being repaired, this may take over an hour" - but it was finished after about 20 seconds.

And yay! I can now boot into Windows again, AND the NTFS-filesystem covers the entire partition. So thanks again, Luciano for the excellent suggestion.

ntfsresize doesn't seem to have any options to ignore the backup sector. However, that message may indicate that there is something wrong with the filesystem. I suggest that you first run ntfsfix on the partition and then boot Windows and run chkdsk.

  • I did both, ntfsfix and chkdisk (including search for bad sectors) - no difference. – Peter Krnjevic Mar 25 '13 at 6:53

I ended up in this situation after trying to clone an ntfs partition onto an SSD. I didn't use the same starting sector (which is a no-no, as described e.g. here), as I wanted to ensure that everything was aligned to the 4K sector boundaries (whether this worked or not is another story). I initially shrunk the original disk to a smaller size than the target SSD, to ensure it would fit. After copying over the partition successfully with ntfsclone, I tried to expand it as you have done, and got the same error. After this, I did the following:

n.b. Do this at your own risk, as a last resort.

  • ran testdisk as per the wiki, which involved something along the lines of (sorry this is from memory):
    1. Chose my partition e.g. /dev/sda1
    2. Chose PC/Intel as mbr type
    3. Option analyze. This should show the old boot sector and backup are identical (but as we know they're not).
    4. Option write boot sector. This confusingly gives a warning saying that the boot sector you're going to write does not match what is on the disk.
  • Reboot. The disk is unbootable.
  • Reboot using a windows recovery media, loading the recovery console.
    1. Run FSCK /F C: (where C: is your drive) - this finds errors and fixes them
  • Exit and reboot, and you should find that your disk has been extended to the max size.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.