0

I'm getting a lot of lines marked as [error] in my httpd's error_log file that look like this:

... 
[Mon Jul 22 12:00:35 2012] [error] Maximum new request methods 62 reached while registering method NONE.
[Mon Jul 22 12:00:35 2012] [error] Maximum new request methods 62 reached while registering method NONE.
[Mon Jul 22 12:00:35 2012] [error] Maximum new request methods 62 reached while registering method NONE.
[Mon Jul 22 12:00:38 2012] [error] Maximum new request methods 62 reached while registering method NONE.
[Mon Jul 22 12:00:38 2012] [error] Maximum new request methods 62 reached while registering method NONE.
[Mon Jul 22 12:00:38 2012] [error] Maximum new request methods 62 reached while registering method NONE.
...

It's a rented virtual CentOS 6 server with a single Joomla! (v.1.5.15, inherited from another contractor. Updating it is NOT an option unfortunately due to heavy core customizations I have no clue about, already tried it, website blew up in my face) setup on it, which doesn't seem to be hindered in any way except for some minor PHP incompatibilities due to eregi() being deprecated (taking care of that right now).

I haven't touched the "default" configuration of the server yet, so it can be safely assumed that options of everything involved (httpd, mysql, etc.) are set at the out-of-the-box value.

Google left me empty-handed, has anyone experienced this ? Is there something wrong with the server ?

2 Answers 2

1

I managed to find the svn commit where this was introduced. I'm not much of a programmer, but as I understand the comments, it's supposed to work like this:

  1. You have the usual HTTP methods such as GET, POST, HEAD etc
  2. Your application may have other methods that your httpd will just pass through to the application.
  3. HTTPD has a limited space for keeping a list of what non-standard methods are used - max is 62 and this can't be changed via any config directive. They are assigned when modules are loaded.

Your application is unusual and it manages to hit this hard limit. Congratulations! It seems you've inherited a black box of magic!

1
  • Looks like it's just the way Joomla! works then. Well, good to know, I'll just ignore those "errors". Thanks.
    – Alex
    Jul 26, 2012 at 6:50
0

Such an errors, in practice, can occurs on some unusual/broken .htaccess file. Try to check all of them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.