A customer has asked for help with this, and given me remote access, and my Google searching is not helping. SU doesn't seem to have anyone available to help in chat currently, so I'm trying here.

I start it up, run the Setup your Internet address and Configure a Smart Host for Internet e-mail wizards, only to be told that the Connect to the Internet wizard must be completed first. Fine, I'll do that.

I start that wizard, it detects the router IP and the Server IP. DHCP and DNS are disabled in the router, and set for the server. At the end of the wizard, I get Windows SBS did not properly configure your e-mail. To correct this, re-run this wizard.

Doing googling, I ran PS scripts, re-configured IIS, and none of this has worked. Has the customer screwed over his server? Or is there a way to recover from this point? It is accessing the Internet just fine (proof: I'm remoting to it)

enter image description here

EDIT: Logs uploaded

Session "WBCommandletInBuiltTracing" failed to start with the following error: 0xC0000035

(Process w3wp.exe, PID 6452) "RBAC authorization is unavailable due to the transient error: The Microsoft Exchange Active Directory Topology service on server localhost did not return any suitable domain controllers."

The mount operation for the gatherer application cf7f8355-fe55-4b3b-a945-060635a824a7 has failed because the schema version of the search administration database is less than the minimum backwards compatibility schema version supported for this gatherer application. The database might not have been upgraded.

The Microsoft Exchange Throttling Service encountered an Active Directory error while building an RPC security descriptor. This failure may indicate that no Domain Controllers are available at this time. The service will be stopped. Failure details: Microsoft.Exchange.Data.Directory.NoSuitableServerFoundException: The Microsoft Exchange Active Directory Topology service on server localhost did not return any suitable domain controllers.
   at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetConfigDCInfo(Boolean throwOnFailure)
   at Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateConfigNamingContexts()
   at Microsoft.Exchange.Data.Directory.ADSession.GetConfigurationNamingContext()
   at Microsoft.Exchange.Data.Directory.Recipient.ADRecipientSession.GetWellKnownExchangeGroupSid(Guid wkguid)
   at Microsoft.Exchange.Data.Directory.Recipient.ADRecipientSession.GetExchangeServersUsgSid()
   at Microsoft.Exchange.Data.ThrottlingService.ThrottlingRpcServerImpl.GetRpcSecurityDescriptor()
   at Microsoft.Exchange.Data.ThrottlingService.ThrottlingRpcServerImpl.c__DisplayClass1.b__0()
   at Microsoft.Exchange.Data.Directory.ADNotificationAdapter.RunADOperation(ADOperation adOperation, Int32 retryCount)
   at Microsoft.Exchange.Data.Directory.ADNotificationAdapter.TryRunADOperation(ADOperation adOperation, Int32 retryCount)

An unexpected error occurred while starting the Microsoft Exchange Address Book service. Error details: The wait operation timed out (258)

The Mailbox Replication service was unable to determine the list of mailbox databases hosted in the local Active Directory site.
Error: The Microsoft Exchange Active Directory Topology service on server localhost did not return any suitable domain controllers.

EDIT 2: As per request, here is the DNS Forwarders configuration inside of the DNS MMC snapin: enter image description here

closed as too broad by MDMarra, mdpc, TheCleaner, sysadmin1138 Aug 14 '13 at 21:20

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Why are you even running the wizards if the box already has internet access? – Der Hochstapler Jul 23 '12 at 22:22
  • 1
    Have you suggested that maybe he should try running his Exchange server on a real OS? Or going with a hosted Exchange solution? Well, that probably not particularly helpful, but maybe the event log entries saying why the wizard failed would be of use. SBS does have event logs... doesn't it? – HopelessN00b Jul 23 '12 at 22:31
  • 4
    @HopelessN00b you are not supposed to do "manual" configuration with an SBS - it's all wizardry land there. – the-wabbit Jul 23 '12 at 22:56
  • 1
    @HopelessN00b Exchange is made to run on SBS. What's not real about that? – Wesley Aug 14 '12 at 20:37
  • 1
    @HopelessN00b How is it not a real OS? It does OS functions, therefore it's an OS – Canadian Luke Aug 14 '12 at 21:03

DHCP and DNS are disabled in the router, and set for the server

You likely have an issue with DNS resolution. The SBS has been designed with the idea of a working company router in mind. While disabling the DHCP server on the router is a good idea, disabling the DNS forwarder is not, as the SBS will try to resolve any of its own external requests through the router's forwarder.

Simply re-enabling the DNS forwarder on the router and re-running the "connect to the internet" wizard should help here.

  • The DNS forwarder was set to (Google's DNS). I added the Router as another forwarder, and turned DNS back on in the router. Running the wizard - No change, even after restarting the DNS Server service – Canadian Luke Jul 24 '12 at 17:11
  • @Luke have you double-checked that it is the forwarder which is set (i.e. a forwarder setting in the DNS Server MMC snapin) and not the resolver in the TCP/IP configuration of the server? The latter has always to point to the SBS server itself, otherwise domain location and any depending services would not work. – the-wabbit Jul 24 '12 at 19:47
  • See edit with picture – Canadian Luke Jul 24 '12 at 20:06

I've recently put an SBS2011 and had lots of problems .. it was really fussy!...

Try running "Fix my network" even though it is connected to the internet anyway and just use the same information and make sure you haven't got any other domain controllers or DHCP servers on the same network.

This sorted my problem, as I manually configured my NICs .. it really doesn't like people changing anything manually

Not the answer you're looking for? Browse other questions tagged or ask your own question.