I have a single server Exchange 2010 installation.

Three times in the past week Outlook Web Access has stopped working, but ONLY for Internet Explorer clients. The forms based authentication login page loads, but no matter what credentials are entered it always returns the message "The user name or password you entered isn't correct. Try entering it again."

Opening just about any other web browser on the same client computer and trying from there with the same credentials works just fine.

This tells me that there is something wrong with the PREMIUM client, but what?

What I have done in the past that seems to have solved the problem, but only temporarily:

  1. Reapplied Update Rollup 4 for SP2 and restarted.
  2. Just restarted.
  3. Recreated the OWA virtual directory and restarted IIS.

I am reluctant to restart the server now in the middle of the day to try options 1 or 2, but option 3 didn't work this time.

Any suggestions? I have tried with multiple IE versions (7 through 9) with the same results.

  • My first honest suggestion would be use a browser that doesn't suck so much. Since that's probably not helpful, I'd suggest clearing the stored login data in the IE client, and (if applicable) having the users authenticate with their fully qualified credentials (domain\user and/or user@domain.tld). Then their cache, then applying standard settings until I could either rule out the problem as being client-side, or fixed the issue. If it took me too long, I'd be very tempted to suggest "IE sucks, use something else." – HopelessN00b Jul 24 '12 at 15:59
  • While I understand the sentiment, it's not that that easy. The client that is presented when using IE is different (and yes, better) than the client presented to any other browser. And I can verify that the problem is NOT client side... I have tried changing the access types to other formats of the username as suggested, and have also verified that the problem is client independent... ANY connection from IE fails with the "Invalid password" message, and ANY connection with a non-ie browser is successful. – Glenn Sullivan Jul 24 '12 at 16:19
  • I just bit the bullet and reinstalled Update Rollup 3 for Exchange 2010 SP2 and the problem is resolved again. But for how long, I don't know. Any suggestions for tracking the changes that might affect this issue as stated? – Glenn Sullivan Jul 24 '12 at 16:20

Reinstalling Update Rollup 3 for Exchange 2010 SP2 seems to have worked. This problem has no returned.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.