Has anyone else experienced this problem?

While browsing folders in explorer over a remote desktop connection, sometimes the file name strings will get corrupted, so they display incorrectly in windows explorer.

Remote desktop (or terminal services) must have some kind of graphical cache for strings, which is being corrupted for particular strings almost at random, especially file names in windows explorer.

I can't reproduce the error on-demand, but once it occurs, you can copy the file name string and paste it other places in explorer, such as the address bar, the "run" dialog, etc... and that exact string will be corrupted there as well. If you type out the string by hand, it also becomes corrupted as soon as you add the final character, even if you type the first part of the string, the last part, and finish by adding the final character... the end result is that once the corrupted string is reestablished, the visual display is wrong (it goes blank, or has the wrong characters).

It's purely a visual defect. I can still edit the string. If I remove a character, the entire string displays fine (because it's a different string). If I add a different character, it also displays fine, but as soon as I add the original character, restoring the original (corrupted) string, the display of the string is either blank or garbled.

Who can this be reported to.. it's clearly a nasty bug.

EDIT: A corrupted string seems to manifest itself visually by being replaced with strings from file property dialogs, such as ID strings, words like "Permission" or "Allow", and file paths; perhaps the bug has something to do with displaying file property windows.

EDIT: Added Image Below. If I resize the separator, the strings will change (they end in "...", so it's a different, uncorrupted string, which displays fine. Actually, you can't even capture this as a full-screen image from within remote desktop, because it comes back without the display glitches! Only by restoring the remote desktop window to a window-ized state, and taking a picture of the client desktop with the remote desktop window open is it possible to see this corruption... so perhaps its a client string-rendering issue.

Remote Desktop Corruption Example

  • In the MSTSC settings (prior to connecting) what do you have set for the Display, and the Experience tabs? Also, is it possible to get a screen grab and post here? – Izzy Jul 15 '09 at 16:46
  • I added an image. It happens with both 24 and 32-bit display settings, perhaps others as well, and with all experience configurations, with and without bitmap caching. If I take a full screen screenshot from within remote desktop, and paste it in paint on the client, there is no corruption. If I instead take a screenshot of the RD client window on the client machine, then it captures the corruption. Notice how the corruption results in replacing exact file name strings with what looks like stuff from file property dialogs. – Triynko Jul 15 '09 at 17:53
  • If I take any one of those "wrong" file names and copy it (it copies the correct text remember), and paste it in notepad, it displays fine. But if I paste that same string in explorer's address bar or in the run dialog box... the corrupted version appears. If i edit the string at all, the corruption goes away... so it's clearly specific file name strings that are getting corrupted, and which ones get corrupted seems random, but it's usually most of them. – Triynko Jul 15 '09 at 17:56
  • maybe something's up with explorer.exe, since everything seems fine in notepad? try killing explorer.exe in the process tab of taskmgr. then go to file->new task->explorer.exe (if it doesn't restart automatically for you) – brad.lane Jul 15 '09 at 18:17
  • notepad uses a different font. the programs on the server are absolutely fine, the strings aren't actually corrupted. the remote desktop client is just messing up the rendering of particular strings, as though it's caching them (for a particular string/font?) and they're getting corrupted or mixed up with other strings. i know this, because I can still edit the strings without error (even though they aren't displaying correctly) and if i take a full-screen-shot of the remote server and paste that in paint on the client, there are no display errors... it's purely a client rendering issue. – Triynko Jul 16 '09 at 16:02

I've absolutely seen what you're describing in RDP sessions to Windows Server 2003 machines. I've been unable to repro the bug and I've probably only seen it 20 - 30 times (out of thousands of RDP sessions), but I've definitely seen it.

I've seen this both in a window and full-screen. I've almost always used the "Low-speed broadband" "Experience" settings, so only bitmap caching and visual styles are enabled.

  • That's about what my experience has been (also with Server 2003 machines) with the latest remote desktop client, but I'm running into this bug frequently to the point where it's becoming annoying and disruptive to my work; try organizing hundreds of files without being able to see their names or better yet... with them having the wrong names displayed appearing as legitimate names. – Triynko Jul 15 '09 at 17:12
  • That sucks. If you get a reliable repro condition I'd love to hear it. – Evan Anderson Jul 15 '09 at 17:33
  • 1
    Yes, I've also seen that on some servers. Like Evan describes, maybe 0.01% of my sessions. The first time I saw this my blood froze :-) – splattne Jul 17 '09 at 11:27
  • Another problem I frequently experience with the "new" remote desktop client is... after locking the session and logging in again, explorer freezes in some kind of desktop resizing loop. The icons shift up and down, as though I was resizing the taskbar from zero height to one row of buttons and back, over and over, and explorer is locked while this is happening. The only way to resolve it is to kill the explorer process and restart it. I wonder if anyone else has experienced that; maybe it's a related issue. – Triynko Jul 22 '09 at 15:48
  • 1
    @Triynko: Haven't see that one. Now that you've mentioned it, though, it will happen to me almost immediately! – Evan Anderson Jul 22 '09 at 16:06

Yeah this seems to be pretty common on the AWS VMs I've connected to.

Hasn't caused any serious issues though.


I've experienced this in the past. Though, like Evan, it's a rare occurence for me as well.

You could try deleting the files in C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Terminal Server Client\Cache

or for Vista C:\Users\username\AppData\Local\Microsoft\Terminal Server Client\Cache

The files will have a .bmc connection, so these are probably the bitmap cache files it creates. Not sure if clearing these files out will do the trick, but you could give it a shot with no ill effects.


Yes I've seen it too, though rarely, and always under tense/harsh network conditions and a reconnect has always resolved it - so I've thought of it as a glitch due to too much packet loss or similar problem... but it's certainly interesting enough to further explore ^^

I'm not sure this is the fact with RDP (but it sure is with ICA) but as far as I know it the local client simulates most Win32 UI stuff like windows, borders, most text, input textboxes and so forth to speed up the display and only gets told what to draw in many cases (almost like vector graphics), and not sent an actual image for everything (because that would be very slow, like VNC ;). Hence, having a corrupted text string due to troublesome network conditions (or a bug) doesn't seem too unlikely.


I have seen the same issue with the Remote Desktop client on different list views (not limited to Windows Explorer). Some observations:

  1. the data can change randomly when resizing the columns (switching from the correct value to a seemingly random value);
  2. if you take a screenshot, the text is displayed correctly;
  3. this appears to only happen with version 6 of the Remote Desktop client (v5 and v7 do not show this issue);
  4. it appears to affect only virtual list views -- with a 'standard' list view, Windows stores the text as part of the control itself; with a virtual list view, Windows sends messages to the application to request the text for an item at a given row and column. This is so that an application can display a large number of items in the list efficiently (e.g. doing incremental updates).

Does anyone know if there is a Microsoft KBA on this?


As with Larry, Remote Desktop worked just fine for me on XP Pro SP2 (I have several sessions open everyday), and I only started seeing this issue after upgrading to SP3. I see this daily and it's really getting to be annoying, so I'd be interested in any workarounds/fixes that have worked for others.


The only workaround I've found is to roll back to the original XP SP2 RD client & DLL file (dated 2004/08/04). Just replace mstsc.exe and mstscax.dll in \WINDOWS\system32 and mstscax.dll in \WINDOWS\system32\dllcache (make backups of the original files first!). This works on XP SP2 & XP SP3 machines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.