I'm building a new XenApp 6.5 Farm, which requires SQL 2008 R2 Express(which I've installed on a machine called vCitrixServices). I installed XenApp on vCitrix1 and started to creating a new farm, but I get this error trying to connect to our database.

DB server : vCitrixServices

XenApp DB Error on a new citrix server

I can connect using MS SQL Management Studio on the DB server using just the server name. (The SQL Server Service says the instance is called MSSQLSERVER)

MS SQL Management Studio - Login Screen

I tried on my machine with Navicat Premium, and I get this error.

Navicat Premium Error - On my machine

Things I tried that didn't work :

  • All the services are enabled (SQL Server/SQL Server Browser and Client Protocols[ TCP/IP, Named Pipes, VIA])

  • Remote connection were enabled.

  • Added rules to windows firewall on vCitrixServices(and even turned it off altogether)

  • checked all network connection from vCitrix1 and my machine, no problems there.

  • Ran cliconfg.exe, and Named Pipes & TCP/IP are both enabled with priority to Named Pipes

  • Named Pipes had a default pipe of "sql\query" Couldn't find if that was a problem or not.

  • Client Tools & DB Engine were installed. (https://stackoverflow.com/questions/360141/how-to-connect-to-local-instance-of-sql-server-2008-express)

I've done a few more things, but don't remember them all... I'll update the question with the results of any new test.


Try appending the instance name to the server name i.e. vCitrixServices\sqlexpress

| improve this answer | |

I restarted all the services then I restarted the SQL Server service. Which fixed the problem and allowed me to connect remotely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.