I want to get away from developing in PHP but doing that is proving to be a massive headache.

I am trying to set up a website with MVC 4, ASP.NET 4.0, on Win7 Professional (64-bit). The website is just the basic site that is set up with Visual Web Developer 2010 Express selecting New Project > C# > Website > ASP.NET MVC 4 Application.

After setting up the application in IIS7.5 I am getting an HTTP Error 403.14 - Forbidden. I've done a ton of research and tried multiple different suggestions on how to solve the problem but NOTHING is working. Here are some things I tried:

Install/Register v4 of ASP.NET. This has been the most annoying thing because everyone else's issue is fixed when they do this but mine is not. Changing the application pool settings: Set to classic/integrated mode Change the user/permissions used by the application pool Made sure 32-bit applications were enabled Added security permissions to folders related to the website (on multiple accounts) I can get a regular html document to show up if I add it to the websites root directory. It seems that the MVC stack is not being called at all. The server wants to display the directory, which I can enable/disable, but the website is not being displayed. Please can I have more potential fixes before I resort to my last desperate act? A baseball bat.

p.s. I'm more than willing to do a skype conversation or a share screen kind of thing if someone wants to dig in deep. I am beyond frustrated with this.


Try naming your sample application default.aspx when you copy it into the web root.

Start by creating a simple hello world app as default.aspx and see if it works. This will isolate any issues with IIS:

<% Response.Write("Hello World!") %>

Also check to make sure IIS is actually configured to serve a default document such as default.aspx.

  • Thanks for the answer. I finally got it to work through your suggestion.So it seems, in my indefinite well of stupidity, I was pointing the webserver to the incorrect folder. I needed to point the webserver to the folder with actual files of the application rather than the folder containing the .SLN file. Sorry to waste your time! – Chris Peterson Jul 28 '12 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.