Have a Netscreen that appears to be functioning correctly (it's in production and has been for several years), but yet is not allowing me into the Web interface on port 80 or 443 (also tried 8080). Tried telneting to 22 and 23 as well. Any attempt to connect times out. I've nmap'ed the IP on the internal interface and all ports show as being filtered, but as far as I recall, it was listening on 80. Also tried the external interface as it was setup for remote management, but can't connect that way either.

It was working last time I tried getting into it (last fall, I think).

I've cycled the power on it twice (pulled the adapter, waited 30 seconds, plugged it back in), but no dice.


Console into the firewall as kageeslin suggested, then do a 'get interface ' and look for something like this:

Interface ethernet0/0(VSI):
  description ethernet0/0
  link up, phy-link up/full-duplex
  vsys Root, zone Untrust, vr trust-vr, vsd 0
  *ip   mac abcd.abcd.abcd
  manage ip, mac abcd.abcd.abcd
  ping enabled, telnet enabled, SSH enabled, SNMP enabled
  web enabled, ident-reset disabled, SSL enabled

Make sure you are trying to connect to one of your manageable interfaces and also make sure that it has a route back to you (get route). Can the firewall ping your PC?

[edited for additional testing steps]

Once you have console access:

Check the admin ports that the web server is listening on:

get conf | inc admin

Try setting a filter for your connection and debug.

clear dbuf
set ffilter src-ip <your ip address>
debug flow basic
[try the connection again]
sh db str
|improve this answer|||||
  • routes should be fine: it's in production (doing NAT/firewalling/IPSec tunnel, etc.) and I'm remoted into the server on the same network as the management interface where I've accessed it before (had it bookmarked). – gravyface Jul 16 '09 at 0:37
  • Are the "manage" lines on that interface still enabled? – Peter Jul 16 '09 at 11:16
  • Could it be that you allowed management access not for your whole network, but only for a specific IP? (You should see that in get conf | inc admin) – Marie Fischer Jul 16 '09 at 13:52

Have you tried to access via console cable?

|improve this answer|||||
  • No, but that was going to be next thing I tried tomorrow when I'm on-site again. – gravyface Jul 15 '09 at 19:27

Have you tried from a local subnet as well, just incase routing is fubar'd?

|improve this answer|||||
  • yeah, no dice. Scrounging for a DB9 cable for tomorrow. – gravyface Jul 16 '09 at 0:35

Theres an odd behaviour with the web interface particularly. If you enter your username and password and press enter, the fields will be cleared and it looks like your password was not accepted. If you click the actual submit button you'll be able to log in. I ended up resetting the whole device before realizing this myself.

|improve this answer|||||
  • Yes, I recall that from before, but this time, I can't even connect. – gravyface Jul 16 '09 at 13:19

If you have something forwarded through the firewall on port 80, the firewall will change its default interface to 8000. Try the ip with port 8000 in your web browser and it should work.

|improve this answer|||||

Hilariously enough, I found my co-worker's question while googling the same question. The answer to this wound up being

set admin manager-ip

set admin port 8887

Admin port might not have been needed, but at least then I could be sure. Previous IT provider had in fact set the admin manager-ip to be the internet IP on the client at the time which was entirely out of date. God bless those guys in the red clown cars.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.