9

I just wanted to test a reverse proxy simple setup, redirecting every request just to google. Anyhow it does not work! Trying to browse on localhost, I just get the apache "it works" default page, but not proxying.

Of course I loaded the modules proxy, proxy_http. Following file is placed under sites-available, with symbolic link in sites-enabled. I also restarted the server. What could be wrong?

<VirtualHost 192.168.1.2:8080>
      ProxyRequests off
      ProxyPreserveHost On
      <proxy *>
      Order deny,allow
      Allow from all
      </proxy >
      ProxyPass / http://www.google.de
      ProxyPassReverse / http://www.google.de
</VirtualHost >
7

The default vhost (which serves content from /var/www, where the "It works" page lives) is getting the requests.

It's loading first, and you haven't specified a ServerName for your new vhost, so the "default" vhost will get every request. Run apache2ctl -S - it will show you how it's assigning requests.

If you don't want to use the default site, disable it with a2dissite default, then restart Apache - requests will then be sent to your new proxying <VirtualHost>.

Additionally, your trailing slashes should always match when proxying. Add them at the end:

ProxyPass / http://www.google.de/
ProxyPassReverse / http://www.google.de/
  • I'm testing out the above but when I run apachectl -S I don't see my port being forwarded. I only see port 443 and port 80. Any ideas? @Shane Madden – FabricioG Nov 14 '18 at 23:22
  • Ugh never mind I was editing the wrong file @Shane Madden – FabricioG Nov 15 '18 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.