12

I'm running (trying to run, actually) Apache 2.4.2 on Windows Server 2003 R2 32 bit (plus PHP 5.4.5 and OpenSSL 1.0.1c, but I don't think that matters), and I'm getting the following line in the error log:

[Sun Aug 05 11:52:39.546875 2012] [ssl:warn] [pid 5712:tid 348] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]

Trying to connect to https://localhost/ gets a 102 - Connection refused error.

What puzzles me is that SSLSessionCache is configured:

SSLSessionCache        "shmcb:C:/Program Files/Apache Software Foundation/Apache2.4/logs/ssl_scache(512000)"

It's exactly the same line of the configuration file I had for Apache 2.2.17 (except for /Apache2.2 instead of 2.4), which runs just fine. Using mod_status, I'm getting no informations for "SSL/TLS Session Cache Status", while I do for Apache 2.2.

I don't think there are many differences between the two httpd-ssl.conf files, mainly between paths, but it seems they're all right.

The virtual server on port 80 runs okay.

What am I missing?

Edit: for those who are wondering, this isn't the misleading warning that someone got when the machine couldn't resolve the ServerName. Apache 2.2 has no problem with it, and I even flushed the DNS cache with netstat /flushdns.

11

The culprit wasn't found in http-ssl.conf, but in httpd.conf.

I suspected that when I saw that the server status wasn't reporting the "SSL/TLS Session Cache Status" section at all, rather than an empty section. It happened that the Include directive in httpd.conf pointed to an old test .conf file instead of httpd-ssl.conf.

Well, duh! This may help other newbies like me in the future...

  • 1
    nice one! this help we with getting apache back on track after upgrading to high sierra – stefan Dec 18 '17 at 10:27
  • What about completely forgetting to uncomment the appropriate Include directive, like I did, and was very surprised why the file was never loaded? I 'out-newbied' you! (note: the first time I tinkered with Apache was... back in 1995, when it was first developed!) – Gwyneth Llewelyn Nov 22 '18 at 18:34
2

I was also having the same issue but it is fixed now.

I tried running the command "netsh winsock reset" in command prompt and restarted my machine.

Problem was.. installed skype recently and after the installation both apache and skype were looking for same port 80. Even if you change the port number for skype it was not working... might be becos of some cache in windows. After changing the port number for skype and running this command it worked for me.

0

Could also be that you have a mismatch between server name and ssl cert. Then it looks in apache/error-log like: server certificate does NOT include an ID which matches the server name.

0

In my case it generated this error because there was some process in windows using port 443 of ssl. Try to disable non-windows services. And removing from automatic startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.