I have a weird issue with Wordpress which I can't figure out how to solve. About a month ago I switched servers and carried my Wordpress files and databases from the old to the new. At the time, I had the old version of Wordpress, the one previous to the version that required php5 (because I didn't have it).

When I successfully moved everything, I upgraded my Wordpress to the latest version. I had some issues with some plugins (unfortunately, I can't remember which ones) which I didn't care that much, so I deleted the files from the plugin directory.

Everything seemed fine so I left it that way until I got an email one day that my blog was down. I went to have a look and all I saw was a blank page. Everything else in my server worked fine. There were no serious crash errors in my Apache log but I did notice that I did not enable php logging. So I made the appropriate changes to the php.ini, restarted Apache and it worked again.

Then, I few days later, the same thing happened. I just restarted Apache to see what would happen and it worked again. Apache error logs didn't show anything serious. Neither did Apache access logs or Ubuntu's system logs. For some reason though, I don't see any PHP log file even though I have set the log_errors = On and error_log to a full file path.

Any help? I don't even know where to start looking.

  • Start with the PHP error_log. Make sure you actually specified a path that exists. – Michael Hampton Aug 5 '12 at 16:32
  • I just copied and pasted the path I have set to the error_log and the directories are there. There is no PHP log file though. I'm guessing that either no logging is happening (and thus no need to create a file) or there are some permission problems (in which case I don't know what to do). – pek Aug 5 '12 at 16:46

I finally found what the cause is, so I'll answer my own question in the hopes that somebody runs in the same problem.

After a bunch of hunting in the Apache logs, googling Wordpress Blank Page and trying everything I found (turns out, there a million reasons why this can happen), I found out that the problem was memory.

The fix was pretty easy from there: I added more memory in wp-config.php

define('WP_MEMORY_LIMIT', '128M');
  • I had a similar problem, this solved it for me. Thanks – Vingtoft Apr 9 '18 at 12:56

If you haven't already made sure there's no suspicious or malicious code on your server, you can try this script to do a quick search: http://25yearsofprogramming.com/php/findmaliciouscode.htm

  • The link no longer worked – masegaloeh Jan 12 '15 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.