On my Mac terminal, printing UTF-8 works in general, but the less doesn't work correctly.

So this works correctly:

$  echo -e '\xe2\x82\xac'   

but piping it into less gives something like this:

$  echo -e '\xe2\x82\xac' | less  

How can this be fixed?

For diagnostics:

I'm using Mac OS 10.6.8. less version 418, Terminal 2.1.2 (273.1).

The output of my locale is this:

$ locale

Okay, I found the answer after some googling. Apparently, LESSCHARSET needs to be set like this:

export LESSCHARSET=utf-8

Now less works fine for me.

| improve this answer | |
  • 1
    I had the same problem on CentOS. This line also fixed it there. – Wim Deblauwe Aug 11 '15 at 13:01
  • 10
    For me what solved the problem was using less -r (display "raw" control characters) – waldyrious Aug 15 '16 at 13:39
  • 1
    This works in Debian 8 too, thanks! – lucaferrario Nov 10 '16 at 14:43
  • Someone should accept this answer! It solves the problem. – lensovet Jan 29 '17 at 7:12
  • 2
    less -r does the same thing but also handles emojis correctly, which export LESSCHARSET=utf-8 does not. – Noah Sussman Jun 8 '17 at 16:18

If you can see some unicode characters in less, but are unable to get less to display emoji, try upgrading less to a more recent version. On Mac OS X, I went from version 458 to 481 and that fixed my problem (for example, git log can now display emoji in commit messages).

If you have homebrew, you can replace the system less with a newer version by running brew install homebrew/dupes/less.

| improve this answer | |
  • Thanks! With newer versions of homebrew, you just need to brew install less to get the upgrade. – Alex Ciminian Jun 3 '18 at 20:51

Works for me with

| improve this answer | |
  • 3
    LC_CTYPE is the important one. However the rules less uses are bizarre: instead of retrieving the encoding from the locale, it looks for the string "utf-8" (or a few other possibilities) in its name.So you’ll need to use LESSCHARSET if you want some other encoding or if your locale name doesn’t match less’s preconceptions. – Richard Kettlewell Aug 7 '12 at 22:25

I googled this and tried the following environment variables which worked for me:

export LC_ALL=en_US.UTF-8
export LANG=en_us.UTF-8

Seeing as I find the LC_ALL in multiple different answers I think this is the correct one. But maybe not the only right answer, there could of course be more correct answers to this question.

Anyway some more googling gave me this description for the variable:

LC_ALL This variable determines the values for all locale categories. The value of the LC_ALL environment variable has precedence over any of the other environment variables starting with LC_ (LC_COLLATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY, LC_NUMERIC, LC_TIME) and the LANG environment variable.

source: http://pubs.opengroup.org/onlinepubs/007908799/xbd/envvar.html

Leading me to think this is the language variable to rule them all :)

| improve this answer | |
  • Please feel free to post less' version number. – Deer Hunter Nov 5 '14 at 16:19
  • sure, less 458 (GNU regular expressions) – Melvin Loos Nov 21 '14 at 10:45

Just update you [less][1]

Do it with brew.

brew install homebrew/core/less
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.