I have a lot of remote desktop brut force attempts on my server. I try to use firwall to allow only my public IP. I use exeptions and scope
but I still able to connect with RDP from others IPs. do you have idea please ?

  • Sounds like you have a blanket exception to allow RDP traffic that's overriding your other rules. But with what little information you've provided, it's really hard to be sure. Or provide much in the way of help. Commented Aug 7, 2012 at 15:17
  • screen shot : link
    – albi32
    Commented Aug 7, 2012 at 15:44

2 Answers 2


Its hard to gather exactly what your scenario and system setup looks like so this is my best guess based on the information provided

Typically you never want to expose your server directly to the internet, especially not Remote Desktop since it is a common port and consistently scanned for on the internet. Once they find it they will constantly attempt to login.

Usually the best defense is simply to run RDP over a different port instead of the standard port. You can find more information about how to do that here.

However, I would strongly advise that you utilize a real firewall device that seperates your server from your internet connection if at all possible. However, changing the default port will reduce the amount of login attempts significantly.

If you still want to setup firewall rules you will have to provide detailed information on what firewall you are using and what the intended behavior should be.

  • thanks Brent , it's an old server that will be closed on the next couples of months so we don't want to invest on it. I will change the port . i try to use the windows Firewall a sreen shot here link
    – albi32
    Commented Aug 7, 2012 at 15:24

I know this is an old question and that you don't provide much info but I faced a similar situation recently that was solved by going

Firewall -> Advanced Tab Selecting Settings for your connection and removing Remote Desktop

The problem was (according to my limited server admin experience) that the advanced settings for my local area connection were overriding my custom list scope keeping the remote desktop open to all.

I am attaching a screenshot to make it easier

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .