I have a SharePoint server have its configuration database, this server is down, when I try to access it it is gives me error:

"Cannot connect to the configuration database"

so I installed WSS 3.0 on another server and I created its configuration database, then I backed the old one up and restored it into the new server, and I have overwritten the old one in the restore action. Now when I open the Central Administration I have an error:

"HTTP/1.1 404 Connection: close Date: Thu, 16 Jul 2009 13:00:31 GMT Server: Microsoft-IIS/6.0 X-Powered-By: ASP.NET MicrosoftSharePointTeamServices:"

The event log gives me that details:
An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

So... how can I extract the old data from the SharePoint server which is down onto the new fresh one, and how can I solve this problem?


Note the following from Restore a farm by using SQL Server tools (Windows SharePoint Services 3.0):

You cannot use the Office SharePoint Server 2007 restore feature to restore the configuration database or the Central Administration content database. You cannot use the SQL Server 2005 backup and restore tools to restore your configuration database to a different farm or topology configuration.

In my experience, moving the configuration database doesn't work too well. I have had more success recreating it using this sort of process.

However, why don't you look into why the configuration database isn't accessible? It seems like overkill to move the database without troubleshooting the problem first. There should be more details about what the problem is in the ULS logs in the '12 Hive', or perhaps even in the event viewer.

| improve this answer | |
  • The old server is hopeless case, it is a very long story ... you can check it here: serverfault.com/questions/41031/… Actually I have moved the configuration database because it is the only way I can fix this problem. The problem is that on the old server I can't open the Central Administration or the Configuration Tool, the database is so strange, it is internal database and no one can view its content. – Magdy Roshdy Jul 19 '09 at 6:10
  • Hmmm... well if you are still struggling then recreating the config DB might be the best solution. At least you know that all of the data structures will be consistent and the product will behave as it should. – Alex Angas Jul 20 '09 at 8:30

On the new box, go to the SQL Config Tools, and the Surface Area Config Manager. Click on Surface Area Config for Services and Connections. In the new window, click on Remote Connections and change it to Local and Remote Connections > TCP/IP only.

| improve this answer | |
  • Thanks Dan, I tried this ... it was actually as you told me to to, I did not changed any thing, the error still her :( – Magdy Roshdy Jul 16 '09 at 14:02

If the old server is still online why not simply figure out why the web farm can't connect to it and restore that connection?

Can you ping the SQL Server from the web farm? Can you telnet to the SQL Server port?

| improve this answer | |
  • The old database server is so complicated, it is so big story. – Magdy Roshdy Jul 19 '09 at 6:21
  • Based on all the other problems it sounds like restoring the connection to the old SQL Server may be the easiest option. – mrdenny Jul 19 '09 at 21:03

Have you tried connecting the farm to the old config database using the psconfig command?

Something like

psconfig -cmd configdb -connect -server <yoursqlservername> -database 
<yourconfigdatabasename> -user <yourusername> -password <youruserpassword> 
-admincontentdatabase <yourCAcontentdatabasename>
| improve this answer | |
  • I tried it but it gives me an error says the "The -connect command is invalid." ... I don't know but I don't have any content database, the configuration database is my content database. – Magdy Roshdy Jul 19 '09 at 6:20
  • sorry, missed out the cmd parameter, I have edited and corrected the command above. – Simon Fox Jul 19 '09 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy