A little background: We have an old rackmount server running a customised version of Fedora, manufactured by a company called Navaho. The server is a TeamCAT, running some proprietary rubbish called Freedom2. We have to keep it going - the alternative is extraordinarily expensive, and the business is not likely to be running much longer to justify changing things.

Through one means or another, it has fallen upon me to try and resolve our lack of root access. The previous admin has fallen under the proverbial bus, and nobody has any clue.

We have no access to the root account for this server. ssh is running on the server, and there is one account admin that we can login with, however it has no permission to do anything (ironic...)

The only other way into the server is with a null-modem serial cable. This works... up to a point. I can see the BIOS, I can see the post BIOS screen, and then I see "Starting grub", followed by another screen with about four lines of Linux information, but then it stops at that point. The server continues booting, and all services come online after around two minutes, but the serial terminal displays no more information.

I understand it is possible to put Linux into "single user mode" to reset a root password, but I have no idea how to do this beyond trying to interrupt it at the grub stage listed above. When I have tried it just froze. It was almost like grub had appeared (since the server did not continue booting) but I couldn't see it on the serial terminal. Which made me think maybe the grub screen has some different serial settings? I don't know... it's the first time I've ever used serial for access!

A friend of mine suggested trying to use a Fedora boot CD. We could boot from USB, so something along this approach is possible but again we still can only see what's going on with the serial terminal, so it might not be achievable.

Does anyone have any suggestions for things I can try? I appreciate this is a bit of a long shot, but any assistance would be invaluable.

UPDATE 1 - 28/8/12 - we will be making some attempts on this today and will post further details later!

UPDATE 2 - 28/8/12 - I tried at least four different distros but couldn't get any further. The end result is always the same - you see "SYSLINUX" etc etc, as if the boot is starting, but then nothing beyond that point. Presumably this is because most Linux flavours have some sort of graphical interface as their next screen, which gets ignored by the serial console.

I am thinking of trying with a really old version of something. Remember we're talking about a server that is about 10 years old here. It really has no power whatsoever!

The oldest thing I tried was Ubuntu 6.06 LTS. This had about the "most" success (I saw several lines beyond SYSLINUX), and the CD spins for ages, appearing to be doing something, but nothing comes through to the terminal. When I boot this on a normal PC, it clearly looks like a graphical interface to me, so again, that might explain why my serial terminal shows nothing. Is there anything older I can try and boot with?

  • 1
    I have to ask. You obviously have physical access, so what's stopping you from plugging in a keyboard and monitor? – John Gardeniers Aug 28 '12 at 10:28
  • Unfortunately it has serial console access only. There is no monitor output. – Sensible Eddie Aug 28 '12 at 12:33

Possibility 1

I would suggest putting a small linux on a USB drive and booting from it. The simpler the better. (More chance you will get everything via the serial connection). I would suggest using Knoppix. Open up a root-shell.

Now, try mounting your disk. If you have no clue about partitions and/or disk have a look at:

cat /proc/partitions

If that doesn't exist, try

fdisk -l

This will give you a list of your partitions that it found upon boot. Now mount your disk with your linux-installation.

mount /dev/hda1 /mnt

(change /dev/hda1to your disk/partition)

Now you can gain access to the system by issuing the following command:

chroot /mnt

Then you can use passwd to reset the root-password. To exit the chroot, just type exit and reboot your server.

Possibility 2

You said you can see grub starting, try using your up/down arrows to stop the automatic boot of the kernel. After that, select the correct kernel and and edit the entry. You will see a line that starts with kernel, hit e to edit the line and put an S at the end of the line (or the word Single). After that, press b to boot it.

This should give you your system in single user mode, where you can use passwd to reset the root-password.

  • 1
    Thank you for this. Possibility 1 is what I will try first, because as mentioned last time I interrupted grub the whole thing just froze on me. It will be a little time before I can feedback on your suggestion as I am taking a well earned holiday next week, but I assure you I will keep you posted! – Sensible Eddie Aug 9 '12 at 17:40
  • Knoppix boots up to a point, but once it reaches the graphical part the serial terminal doesn't send any more data. I will try a different flavour of Linux... – Sensible Eddie Aug 28 '12 at 12:34

You could also try the DarkSide: i am sure such an old Fedora has many active vulnerabilitys and you can use it to train your security skills and gain r00t access :)

  • We're having such difficulty with this that we would try any method. It's not something I have any experience of, though. – Sensible Eddie Aug 28 '12 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.