Is there any utility out there that allows me to paste the password in my clipboard to Windows Server 2008 R2 RDP login screen as if I'm typing the characters directly from the keyboard? I login a lot to different servers and use ClipMate to manage and pull up historical clips.

  • 2
    I will leave this as a comment instead of a answer as it does not provide a solution, but the reason you can not paste in rdp is copy and paste is handled by rdpclip.exe which is run in your user context. If you have not logged in yet, rdpclip has not started yet. However there may be client side solutions to this, and I look forward to watching this question. Aug 9, 2012 at 20:31
  • Have you tried saving the credentials in an RDP file?
    – Jim B
    Aug 9, 2012 at 21:41
  • If anyone feels that this is unfair (like me), and that CTRL+V should work here as well – consider up-voting this item on Windows Feedback Hub: for normal users / for insiders.
    – Igor
    Dec 25, 2017 at 13:23

5 Answers 5


Actually, yes.

As pointed out by @ScottChamberlain, the reason you can't do it with the clipboard is that the program responsible for copy and paste in Windows is run in a user context. Until you log in, you have no user context, and it's not running.

However, that's not the only way to "copy and paste" text or access the clipboard. The password vault I use has a "paste into current field" option, and (to my surprise), it actually does pass this to the password field at the Remote Desktop login screen. Likewise, VNC and OoB-management technologies allow cutting and pasting into the login screen, because they don't use the unlogged-into RDP session's context to try to pass the clipboard contents.

Having said that, I don't find this feature particularly useful. Use a connection management program that lets you save your RDP sessions with username and passwords, and all you have to worry about is double clicking the connection.

I use mRemoteNG, which is freaking awesome. All my RDP, VNC, SSH, telnet, and even http/https connections are saved in there. Free and I'd pay hundreds of dollars for it, straight up. Got thousands of connections saved in there, and never have to type a password for any of them. (And before anyone says it, yes, my connections file is kept in a small Truecrypt container.) Yum, FOSS.


Contrary to what the other "answers" for this question say (including the accepted one), there is indeed an easy way to do this, also if you (like me) for different reasons (most likely security related) don't want to save the password in the RDP connection shortcut/file on your computer.

In the RDP connection dialog (i.e. pre-connect), enter the username, and also put the checkmark in the option "Allow me to save credentials" (don't stop reading here, we will NOT actually save the credentials after all!).

Now when you press connect, you will be presented with a system-local credentials dialog, where the username is pre-filled, the password box is empty but possible to paste right into without any fuss at all, and the option "Remember my password" is pre-checked.

Now, simply paste your password, and also UNCHECK the checkbox for "Remember my password", then click the "Connect" button.

Bam, you're in, and the password will NOT be saved locally after all!

Please accept this as the real answer for this question, instead of the currently selected non-answer.


mRemoteNG is a life saver, but when you have to change a password over RDP the lack of copy/paste is a huge hassle of you want to use a really strong password.

For this, I use the "auto type" feature of KeePass: https://keepass.info/help/base/autotype.html

(Note that the default sequence is for auto type to enter username & password then hit enter. This isn't what you want if you're trying to change a password. In that case, change the autotype value to {PASSWORD})

  • 1
    This is genius! You're my today's hero ;-]
    – metalnoise
    Jan 24, 2022 at 15:03
  • 1
    This works for me, with the caveat that the system-wide hotkey for Auto Type doesn't work when RDP is active. So I select the entry, press Ctrl+V to activate Auto Type and then immediately click the RDP window to have the key strokes be redirected to that.
    – asontu
    Aug 16 at 14:56

Install and use a newer RDP client. Windows 2008 supports NLA. With NLA you can provide your credentials to the RDP client before the RDP session starts. Copy and paste works fine in that case.

Or you could even just save an RDP file per host with stored credentials.

  • 2
    The RDP client does allow the storing of passwords, however if the remote machine locks due to inactivity you are left with a password dialog you can't paste into. You therefore have to disconnect and reconnect to the machine to use the password saved for the RDP.
    – Tom John
    Jul 22, 2019 at 13:42

In my case the underlying problem was that even though I had the correct credentials saved, it would still not log me in automatically. Updating the saved credentials would not make any difference, and it wouldn't show a message saying the credentials were wrong but just take me to the user select screen.

To solve this, I just deleted the old credentials (rather than updating them) and tried to connect again. When it prompted me for the password I entered it and told it to remember my credentials. For some reason when doing it this way its now remembering my credentials correctly again.

You must log in to answer this question.