I trying to configure Mail server on Mac and I almost did it... I can login. I can successfully send/receive emails to/from another emails withing the SAME domain. I can successfully send emails to DIFFERENT domain. But when I try to receive Email from DIFFERENT domain to my server domain - it's not work :( I tried to send it from Gmail and got following error: "Google tried to deliver your message, but it was rejected by the recipient domain 450 450 4.1.1"

  • I have registered a domain name that points to my server IP

  • My Mac connected to internet via router but I already moved it to DMZ zone (outside of router firewall), so it houldn't be a reason.

Please share your experience or your thoughts about it!

  • "It doesn't work" is a poor problem description. Please give us something to work with (log messages would be a good starting point). – voretaq7 Aug 10 '12 at 20:57
  • wtf? I wrote an error message and a code "450 450 4.1.1". Do not work means - email is not received. please read it first before thumbsdown :) – Dmitry Aug 10 '12 at 21:03
  • 4
    So read the error message. It says that GOOGLE was unable to deliver the mail because YOUR server REJECTED it. You would need to look into why it would be rejecting it which are thousands of possibilities. @voretaq7 is right, you need to find and/or provide log entries from your mail server (computer) to help in diagnosing why it would be rejected. As it stands now your question does simply say "I have an error, please help!" which doesn't help us help you. – Brent Pabst Aug 10 '12 at 21:23
  • 1
    @Dmitry SMTP code 450 is a generic temporary failure (No ; Try again later) code. Nothing you provide after that has any meaning without context from the server generating the code (your server), which can only be obtained by looking at the mail logs on your server. Lacking access to your environment, nobody on this site can help you unless you give that context. (It would also help other mail admins if you configure your server to give useful info in its rejection messages rather than a nondescript 450 4.1.1, but that is a separate issue...) – voretaq7 Aug 10 '12 at 21:38
  • Hi All. ok, it's clear now. I will check the logs and will post it here. Sorry for dumb question – Dmitry Aug 11 '12 at 8:07

I found mistake. I was digging inside server settings but I totally forgot about domain settings. I had to setup MX records. If anyone will have the same problem - when email server works locally but do not work from outside - I think the first place to search is a domain settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.