Cant find any answers anywhere so here goes.

I am trying to CREATE a new virtual machine using the virt-install command from a console on a Debian wheezy install.

I keep getting the following output:

Starting install...
ERROR    internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
inet_listen_opts: bind(ipv4,,5951): Cannot assign requested address
inet_listen_opts: FAILED

I assumed that the port (5951 in this case) was being used judging by the error message and other sites I visited for an answer, but the same error occurs whatever number I use for the port. I cant see that port being listened upon in netstat either.

Anyone have any ideas what may be wrong?

  • Is your lo interface up? Aug 11, 2012 at 19:59
  • You solved it Michael nice one :) If you add that as an answer, I'll make it the accepted answer and give you the points.
    – chrismacp
    Aug 12, 2012 at 15:21
  • Done :) Glad to hear it's fixed. Aug 12, 2012 at 16:44

1 Answer 1


Check to make sure your lo interface is up and running properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.