0

I have an interesting problem. I can confirm that the OpenVPN server is working because I can connect successfully on other Windows machines. On my personal mac laptop though I can connect but the workstation never receives an ip from the server. I have tried all the mac OpenVPN apps (OpenVPN Connect, Viscosity, Shimo.) They all connect successfully, but I have no IP on the TUN/TAP device. I have also tried reinstalling/uninstalling the drivers as well. The machine is now running on Mountain Lion although I was having the same issue in Lion as well. Any ideas what could be causing this issue?

1 Answer 1

0

There used to be issues with OSX and bridging. We recently had success with using routing without nat. If this doesn't fix the issue can you post logs from the mac and your server config?

1
  • Hi Tawm, thank you for the swift reply. It seems the answer comes to me as soon as I post the question in a forum. I don't know why it is working now, but I was able to fiddle it into working.
    – Dobler
    Aug 11, 2012 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .