I have a shared hosting account at Jumba running Linux kernel 2.6.9-103.ELsmp (don't know if that helps) with cpanel 1.0 (RC1).

I am using the WordPress plugin Backup Buddy, which requires HTTP loopback connections to monitor / complete backups. This works fine on memelab.com.au, but doesn't work at any subdomain (e.g.: staging.memelab.com.au).

Is it possible to setup an A record or some such to remedy this?

I'm aware of a workaround, (setting WP_ALTERNATE_CRON) but I find this unsatisfactory due to the messy URLs.


Here is the reply from my host:

…as main domain have it's own separate DNS entry it have localhost entry which helps for looback connections where as subdomains don't have separate DNS zone, so it is not possible to create looback connections for it.

I have cpanel access to the 'advanced zone editor' - is there anything tricky I can do there? maybe (I remember reading that there were at least 8 available local IPs available on (some) Linuxes.)

All the A records point to the server IP, with the exception of localhost.memelab.com.au which points to

I've just tried entering a new A record: localhost.itours.memelab.com.au pointing to I still get the warning in Backup Buddy that loopback is not active, and Cpanel won't let me enter (guess it doesn't work like that!)

nslookup itours.memelab.com.au

Non-authoritative answer:
Name:   itours.memelab.com.au
  • On the machine, what do the subdomains resolve to? This could be a problem with virtual hosts, or it could be a problem with not listening, or it could be a problem with name resolution. – Falcon Momot Aug 13 '12 at 3:12
  • hmm.. not sure I can answer that, @FalconMomot! The subdomains are all subdirectories of the main domain - thanks for looking! – ptim Aug 13 '12 at 11:01
  • Assuming you have shell access to the server, you can simply use nslookup to determine the local resolution. – Falcon Momot Aug 13 '12 at 17:43
  • great tip, thanks.. but I have no idea what it means! I added the result to the post... is the server IP for the main domain and all subs... – ptim Aug 13 '12 at 18:37
  • Is all of itours.memelab.com.au protected with basic HTTP authentication? If so that is probably why "Backup Buddy" isn't working. – Mark Wagner Aug 13 '12 at 19:30

I fixed this problem on my VPS by allowing sub accounts to run the ping command.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.