We are in the process of migrating to Windows Azure, and we would like to connect our current servers to the Azure database to smooth the transition process.

I change the connection string to point to the Azure database, but as soon as I do that IIS will return a blank response (content-length 0, HTTP 200 OK). I have tried turning custom errors on, off, and also looking in the event log but there is nothing there. (edit: we are not deploying to Azure, merely pointing the database in web.config an Azure database.)

We can confirm the connection is working via another box, SQL Server Management Studio, and telnet on that machine.


It seems it's just this one project that's not working, I am able to get the other projects to point to the Azure database just fine.

  • What type of application are we talking about here? MVC? Either way if the server is returning a 200 OK you may want to turn to remote debugging to figure out what might be happening inside the code. It sounds like a code related issue here that may be causing the worker process to fault suddenly. – Brent Pabst Aug 13 '12 at 19:02
  • Yes - it is an ASP.NET MVC3 Website. Why would that occur if just the database mapping changed? It works when I run the website with the same Web.config on the development machine. I have also looked in the error log - nothing. I can't set it up for remote debugging either and that server doesn't have VS2010 installed - do you know of a lightweight debugger I could install on that server? It is a development server, so it's not critical. – Julia McGuigan Aug 13 '12 at 23:49

Just to clarify: If you run the app via the Windows Azure Emulator locally, yet pointing to the Windows Azure SQL Database, everything works correct? And... when you then deploy said app to Windows Azure and hit it with your .cloudapp.net url, you have trouble?

Assuming that's the case: Did you double-check your web.config setting related to session storage? By default, Windows Azure sets web.config to point to SQL Express locally (or in the latest SDK, SQL Express 2012 LocalDB), neither of which exist in Windows Azure when you push to production. If that's the case, you'd need to point your session store to Windows Azure SQL Database (or cache service).

This is only a guess, since things stopped working as soon as you pushed to the cloud...

  • This is not correct. We are not "deploying to azure". I am pointing a development server sitting on a Virtual Machine that we own to an Azure database. Furthermore I tested using regular debugging (by starting the ASP.NET MVC project, not the Windows Azure emulator. We don't even have a cloud project configured for this project, we are just trying to point it at an Azure server. See recent edit. – Julia McGuigan Aug 15 '12 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.