The folder /var/www was mounted during init, using:

mount -t vboxsf cuckoo_shared /var/www/ -o uid=1000,gid=1000,rw,dmode=755

Now, all the files belong to my user jdrummond as default. And also have 755 as default mode.

But now every chmod that I try to run doesn't seem to work: chmod try

My doubts on this are:

First: why is my index.php file 777 even when I said it should be 755 on the mount command?

Second: why isn't my chmod working?


I've tried to run the chmod command with sudo but it also didn't work.

Virtualbox 4.1.18:

Host = Windows 7

Guest = Ubuntu 11.04.

Edit: Just tried the same in another machine, also with the same specs and:



  • Which VirtualBox version are you using? – quanta Aug 13 '12 at 3:07

I'm assuming that the files are stored on an NTFS or FAT filesystem on the Windows host. NTFS and FAT have no concept of *nix executability, and so it is not possible to store this information when you try to chmod a file. This is also why all files are executable -- in order to be able to execute any files, they all have to be made executable.

  • Actually no. Check this weird behavior: i.imgur.com/V7xVq.png (Another machine with Guest Ubuntu 11.04, Host Win 7) – dmmd Aug 13 '12 at 9:13
  • @jlcd What part is weird? That the read permissions aren't removed? The rest is expected. – mgorven Aug 13 '12 at 17:43
  • I don't get why it accepts chmod 000 but not chmod 644 – dmmd Aug 13 '12 at 22:13

Since the folder is shared by the host, I suspect that you cannot change the permission from the guest. Do a chmod on the host to see if it works.

  • Host = windows. – dmmd Aug 13 '12 at 4:05
  • Also does not work when host is Linux. The file is executable on the host, but not in VirtualBox. – Nateowami Jun 4 '18 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.