1

I am trying to run Shared Folders under a different domain user according to one of user's answer for my other question How do you know who or what is locking a remote file?

runas /user:domain\user fsmgmt.msc

Even though running fsmgmt.msc by itself works fine, I am not able to run it when combining with runas. (domain\user <-- I am using a valid user name)

C:\>runas /user:domain\user fsmgmt.msc
Enter the password for domain\user:
Attempting to start fsmgmt as user "domain\user" ...
RUNAS ERROR: Unable to run - fsmgmt.msc
2: The system cannot find the file specified.

Is that intentional or am I supposed to put location of fsmgmt.msc in PATH environment variable? Questions: - How was I able to run fsmgmt.msc without updating PATH? - Is it possible to runas a different user for fsmgmt.msc?

2

Try running MMC instead:

runas /user:domain\user "mmc fsmgmt.msc"

| improve this answer | |
  • +Marked as Answer: Worked like charm – dance2die May 4 '09 at 17:52
1

Perhaps it was not in your path...

try:

runas /user:domain\user %systemroot%\system32\fsmgmt.msc

| improve this answer | |
  • It was in my env. path. And I didn't know that I could invoke a command through env. variable names... Thank you for your answer, MathewC. – dance2die Jun 10 '09 at 18:12
0

I am providing you the steps that worked via GUI

Please search for fsmgmt.msc in the search bar and open the file location by right clicking on it.

Then please try to Hold down the shift key and right click on the application/program or shortcut which you wish to open via different credential

Please refer the below article for more information http://www.windowscage.com/how-to-run-application-as-different-user-in-windows/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.