2

I operate a cPanel/WHM server on CentOS 5.8 which is running MySQL 5.5.24. It seems that ever other week or so, some clients websites exhibit the following error:

SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown storage engine 'InnoDB'

At first, I thought this was a configuration problem after migrating the cPanel/WHM server to a new machine, but all configuration was correct (and no, skip-innodb is not present; and yes, SHOW ENGINES; does return InnoDB). Long story short, I found that all I need to do is service mysql restart and the error goes away immediately. A week or two will go by, and it's back again. Each time, all I have to do is restart the MySQL server. And to really make this odd, it only affects some hosting clients, even though they all share the same MySQL server.

If this issue has already been discussed somewhere, it's difficult to find -- this error message is popular, but the restart fix seems rare.

Ideas?

migrated from stackoverflow.com Aug 15 '12 at 8:48

This question came from our site for professional and enthusiast programmers.

  • 1
    Could it have something to do with your InnoDB settings? One of the comments on this link seems to indicate that it could have something to do with memory usage. (Google cache link because the original is down.) – Bobby W Jun 18 '12 at 15:07
  • wouldn't this be more fitting for serverfault? – Nanne Jun 18 '12 at 15:18
  • @Nanne: you might be right -- I'm so used to coming to SO for programming stuff that it didn't even cross my mind! I flagged it to be moved to StackExchange DBA. – Matthew Clark Jun 18 '12 at 15:36
  • @BobbyW: that was an excellent find. I checked the innodb_buffer_pool_size (using SHOW VARIABLES;) and found it to be 134217728 (which is 128MB). That doesn't seem too high, as the system has 768MB of RAM. – Matthew Clark Jun 18 '12 at 15:43
  • @MaffooClock Did you find an fix to this issue? 2 of our cPanel servers are doing the exact same thing. – Wireblue Jun 13 '14 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.