According to Intel and Dell, by board is technically a 'desktop' board and they therefore do not support Intel USB 3.0 eXtensible Host Controller drivers for Windows Server 2008 (R2 x64). I'm trying to find a workaround. I found an entry on someone who tried to tackle this, but I can't make his fix work for me. Below, I have copied both his entry, and my reply. I'm a loyal stackoverflow user, and hopefully the people here at serverfault can help me:

anyforumuser Re: GA-Z77X-UD5H USB3 Drivers not installing? « Reply #6 on: July 05, 2012, 04:12:59 am »

Thanks to JoeMiner , his process for the network drivers gave me the clues to figure out to get the USB3 drivers working. I have got the intel USB3 drivers working at full speed in win server 2008r2

you have to edit the following file : 1. mup.xml in change the "Windows7" to "W2K8" 2. in setup.if2 under [groups] line starting with "HSCSDRIVER " change the "IsOS( ... )" entry to "IsOS(WIN2008_R2,WIN2008_R2_MAXSP)"

  1. inf files for all copy the content of the [Intel.NTAMD64.6.1] group to the [Intel.NTAMD64.6.2] group

  2. driver folders. here i am not entirely sure which is correct so there are some double up's.

    in the drivers folder copy the "Win7" folder to "win2008" , "win2008_r2" and "x64"

    ie your drivers folder should now contain the "win2008" , "win2008_r2" and "x64" folders and they contain contents of the win7 folder (the inf files should of already been fixed)

Run install , It should install properly and work now. You will have to reboot If it doesn't work remove the intel usb3 controllers from device manager and get it to "scan for hardware changes"

Good luck !!!

benevida Re: GA-Z77X-UD5H Intel Network Drivers not installing? « Reply #7 on: August 13, 2012, 02:21:14 pm »

Thank you anyforumuser! A process for getting this driver installed was exactly what I needed.

However, I've hit a snag. I believe I've followed every step exactly as written, but I'm getting an error during installation. I get the message "One or more files that are required for installation are either missing or corrupted. Setup will exit." Behind the error, the 'Setup Progress' shows the current step as "Copying File: C:\Program Files (x86)\Intel\Intel(R) USB 3.0 eXtensible Host Controller Driver\Drivers\iusb3xhc.man". I've checked the installation files, and iusb3xhc.man seems to be a viable file in all of the Windows 2008 sub-directories of the Drivers folder. Therefore I don't see how the file could be missing and I doubt that it is corrupted, (although it does NOT exist in the \Drivers\HCSwitch folder). I opened 'Setup.if2', and there are two aspects to the step of copying iusb3xhc.man that caught my eye. First, the steps immediately preceding are set to 'error=ignore'. If they hadn't completed successfully, this is the first step where we'd hear about it. Second, this is the first step where the relative path '%source%\drivers\%_os%\%_ia%\' is used. If I haven't named the Windows 2008 sub-directories correctly, I could see where things are fouling up.

In any event, if someone could take a look and make suggestions I'd appreciate it. Thank you.

  • 1
    Installing hacked drivers creates horrifying problems for SAs, so you're probably not going to get much help here. It's just a very, very bad idea from an SA standpoint. In fact, it wasn't so long ago that I told someone that the next issue I have to troubleshoot because some user installed a hacked driver will result in me destroying the hardware with that user's head. – HopelessN00b Aug 23 '12 at 20:41

Same issue here. Just replace '%_os%/%_ia%'(setup.if2) with 'win2008_r2/x64' or one of the other directories where the drivers are copied to. It worked fine for me. I'm not sure where _os is pointing to. 'set' shows that OS points to 'Windows_NT'. Rather then figuring out where _os is pointing to just replace the variables with fixed (but known) values.

| improve this answer | |

In my case, I believe the problem is caused because the directory win2008_r2 is not the right one.
Instead, with the changes to the inf files. I installed the driver from the device manager pointing to the driver in win2008_r2/x64. It installed but returned also an Unknown device error. Did it again for the unknown device and it looks like it worked.

| improve this answer | |

I found a Renesas driver using add hardware that worked for 2008 r2, I had to manually load the drivers for mine kind of like it was NT 4.0

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.