15

I've been having difficulty with connecting to my IPv6 address via rsync. Because the argument for the destination folder is colon-separated, the IPv6 address disrupts this like so:

root@fdff::ffff:ffff:ffff:/path/to/dest

How do I use rsync with an IPv6 address via SSH?

21

You'll want to wrap the address in brackets like so:

rsync -rtlzv -e ssh /path/to/src 'root@[fdff::ffff:ffff:ffff]':/path/to/dest
1
12

Try placing the IPv6 address in brackets, like this:

root@[2001:db8:1234:5678:feed:face:dead:beef]:/path
5

I've run into the same issue and found out that the accepted answer did not work with my version of rsync (2.6.9) when using user@ as prefix

As a workaround you can use the -l user option of ssh:

rsync -e 'ssh -l root' /path/to/src '[fdff::ffff:ffff:ffff]:/path/to/dest'
3
  • 1
    That version has got to be more than 10 years old. Why are you using such an old version?
    – kasperd
    Dec 31 '17 at 0:27
  • 3
    It's the default shipped with macOS 10.11 Jan 1 '18 at 9:16
  • Thank you! I had this problem on OSX myself (10.12). Works perfectly, none of the other answers work.
    – Someguy123
    Oct 3 '18 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.