0

I have a multi-domain certificate I'm trying to install on IIS 7.0.

When I use the IIS manager to complete certificate request, I get the error:

There was an error while performing this operation. Details:

CertEnroll::CX509Enrollment::p_InstallResponse: ASN1 bad tag value met. 0x8009310b (ASN: 267)

One possible solution I found was to run certutil (after importing the cert via certmgr.msc):

certutil -repairstore my "certificate thumbprint"

But this gives me the error:

CertUtil: -repairstore command FAILED: 0x80090011 (-2146893807)
CertUtil: Object was not found.

I also tried importing the new certificate into IIS7, after converting it to a pfx file. IIS takes it but I can't bind it.

The error I get when I try to bind it is :

There was an error while performing this operation.

Details : A specified logon session does not exist. It may already have been terminated.

Any help is appreciated.

2
  • Does the certificate have a private key? – Greg Askew Aug 23 '12 at 18:27
  • Yes. I still have the certificate sitting in certificate enrollment requests. When I double click it, it says " you have a private key that corresponds to this certificate". – James Aug 23 '12 at 18:46
1

I ended up just getting a new certificate.

Here are a some links from my research:

http://blogs.msdn.com/b/webtopics/archive/2009/01/03/asn1-bad-tag-value-met-error-when-processing-a-certificate-request-in-iis-7.aspx

http://forums.iis.net/t/1147928.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.