I am having a huge performance problem with my Windows Xp virtual machine. The mouse kind of stutters and disappears, then reappears, rapidly, repeatedly. It is crawling. The strange thing is that it starts out fast, but the performance degrades after a while. I tried actually setting no page file on the host. That worked for a while. I have all my host PC related performance options set to maximum performance. My host has 4GB of memory and a 2 Ghz core 2 duo with VT option enabled in the bios. The XP machine is a clean install, and works great on another computer with the exact same specs (we ordered 2 of the same laptops). The other laptop has Windows 7 build 7100, this one has Windows Vista SP1. I need help, this is critical.


You need to change "hardware acceleration" to full

open dislplay properties > settinns tab click advanced > troubleshoot tab

move slider to "full"

that should do it!


When you say it works fine on the other machine, did you copy over the vmware files to the other laptop and mount it or is it a separate installation?

Do you have VMWare Tools installed?

How much memory do you have alloted to the VM? Have you tried raising/lowering the amount dedicated to the VM?

  • I have tried with 1024 and 512Mb of ram. Yes it was copied from a file server to both laptops. So its the same exact VM image. – user13394 Jul 17 '09 at 15:08
  • 1
    I would run perfmon on the host and in the VM. Look at Avg Disk Queue, CPU usage, paging and free memory usage on both. See what is happening when you start experiencing performance issues. – Will Jul 17 '09 at 15:16

As will stated, do you have the latest VMWare tools installed?

  • VmWare tools is installed. I'm not sure it's the latest, but we used VmWare Server to create the VM and we recently downloaded it, last week. This is all recent work. So I assume that the VmWare Tools we have installed is at most as old as what was recent last week. – user13394 Jul 17 '09 at 15:25

Is the screensaver enabled in the client OS?

  • Yup I did just do that, but it had no effect. – user13394 Jul 17 '09 at 16:45

Have you tried to disable or disconnect the physical cdrom drive through the vmware player configuration? I am unfamiliar with the player but with the workstation version of vmware I have to turn off "Connect At Power On" for the physical cdrom drive or I experience a great deal of slowness due to CD-ROM drive polling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy