Hardware: S50N

Firmware: FTOS

Problem: We're trying to PXE boot some servers that are connected via port-channel interfaces with LACP.

Current Work-around: we PXE boot a server with a single interface (eth0), and then use a Perl script to turn up the port-channel interfaces after the server is built.


Is anyone doing anything similar on Force10 S50 switches with FTOS? If not, is anyone doing this on another S series, or larger chassis-based Force10?

I'm wondering if Native VLAN will solve this, since ports in a port-channel cannot explicitly have a VLAN set, and they don't seem to use the tagged or untagged VLAN that the port channel is in. I will confirm this next (I think it's the only thing I haven't tried)

Juniper Example: http://broken.net/openindiana/how-to-pxe-boot-systems-on-lacp-using-juniper-switches/

Cisco: there are plenty of documented ways to solve this issue on IOS and Nexus

Update/Edit: since there seems to be no way to use interface or port-channel mode commands to get the individual interfaces to show up in spanning-tree (rtsp in this case), the ports should never go into a forwarding state. I'm not going to mess with it anymore unless a) someone that has experience passes it on, or b) Force10 comes up with a solution for this (I'm guessing it will only be introduced on other S platforms (S55, S60), since the S50 seems to be near EOL). I'm basing that on the fact that the Open Automation type features are only being supported on the newer switches.

  • I like your workaround, are you PXE booting servers so frequently to need this? I could see this being a problem with vCenter's PXE provisioning methods, but typically the management NICs are not LACP, just round robin failover. Aug 27, 2012 at 19:52
  • These are straight-up Linux bare metal servers for OpenVZ - there's no vCenter involved ;) Another new requirement is PVLANs, so I'm trying to convince the powers that be to ditch bonding altogether. I'm still curious to see how someone else is solving this. Aug 27, 2012 at 20:35

1 Answer 1


This question is a bit old, but I ran into this issue with a Force10 S4810 switch and this is the first result on Google. After consulting with someone from Dell Force10, they recommended I use this configuration:

lacp ungroup member-independent port-channel <1-128>

If the members of the port channel are not up, they will revert to switchports.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.