I have a client computer (win 200) that can bring up and browse shares to a server (SBS 2008) based off the server name, "server", but not IP, so \\server\ works while \\\ does not work.

On the server's firewall log, I see traffic that is allowed from that IP address when I try to request \\server\ over the file and print sharing ports, specifically 445. Even tried a route add MASK -p. No love. Also, I can telnet from the client machine to server over the file and print sharing ports (139 and 445) and that works just fine. It's just share browsing by IP that fails.

Thoughts? Thank you!


  • 1
    What's the error message on your client computer when it "can't browse"? – Evan Anderson Jul 17 '09 at 16:57

Do you see anything in the firewall log when you try to access it via ip address?

The next step for me would be to install Microsoft Network monitor on the client and server, start a capture on both, try to access the server via ip address, and then look at the capture results. This should give you some clue as to what's happening.


I'm going out on a limb here to ask if you are entering in the IP as such (direct from your post):


..when in fact, if you're trying to browse the shares (via SMB) on a Windows machine the proper way is:


Hope it's just a simple case of syntax error. Although if you're doing \servername as well, then I would be confused as how one '\' works for the server name. Either way, I'm sure I've oversimplified this issue. Please let us know if it is a syntax error or not.

If that double backslash is not the issue, off the top of my head I'd imagine a subnet mask error. I'm not sure if your example of is accurate or not but I don't recall ever seeing a subnet like that either. I thought the last octet allowed was .254.

Can you supply a little more detail about the network itself, the hosts etc. etc.? Maybe that will narrow down the possible answers to your issue.

  • The double slash was in the question, just not formatted so that we'd see it. I fixed that in the original post. – squillman Jul 20 '09 at 17:34

i wonder if this issue is solved or not. Just my 5 cents here: on your client-pc you wish to access your server with the IP-address, so what do you exactly expect? Now as you get a access throu \server\, switch to a console and look at the output of an arp -a. there you will see the ip's which your client-pc has a connection. May be that \server\ is solved by your dns with a totaly other ip than you expect.

hope that helps to get some light in the dark.

peace Ice


By default, the Windows SMB server does not allow aliasing. If you have a \\SERVER1\share and have a DNS CNAME (for example) called WAREZ pointing to SERVER1, \\WAREZ\share will not work.

Fix is a registry key per MSKB 281308. You won't need the associated hotfix.

We use the fix on a SBS 2008 network with mixed Mac/PC clients that need to access a music library that is aliased so we can move the library (a USB HD) between machines as needed for maintainance.

  • This isn't relevant as he's trying to access it via ip address, not an alias. – joeqwerty Sep 25 '09 at 1:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.