9

At our school we use thin clients that connect to a Windows 2008 R2 server using Remote Desktop Services. This works very well.

One problem we still have is the login timeout for the RDP connection. When the thin client starts up, it shows the server login screen. However, after a small amount of time (one minute or so) the RDP session disconnects and the thin client shuts down (as it is configured to do). This is a problem for teachers that are used to powering up the computer at the start of the day and logging in when they first need it.

How can we change or disable this login timeout? We have looked at the various session timeout values, but there is nothing there to help us.

  • There is a setting in the registry named DelayConMgrTimeout. Could this have something to do with it? – jan.vdbergh Aug 30 '12 at 7:47
11

After some more searching on Google, I managed to find a solution.

The login timeout is set in the registry, with the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Simply add a new DWORD value for LogonTimeout, containing the timeout value in seconds. After that, restart the Terminal Services service. (If you are connected via Remote Desktop, your session will be terminated.)

| improve this answer | |
0

For those arriving at this post, looking for a solution with a Citrix Environment the same value can be used in the Citrix keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\ICA-TCP

(or ICA-SSL , ICA-CGP etc)

| improve this answer | |
-1

This works on our windows 10 machines:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp

Change: SecurityLayer From: 2 To: 0

Reboot

(Should only use for internal / segregated machines for security reasons)

| improve this answer | |
  • Looking at documentation of the setting I don't see how this answer should answer the OP question, which actually was answered correctly years before by the same users which asked – ceztko Sep 7 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.