I have a laptop that will not boot. Sony Laptop windows XP media center edition. It blue screens with:

Technical information: STOP: 0x0000007E (0xC0000005,0x000040D8,0xF79E5548,0xF79E5244)

No listing as to which driver caused the BSOD.

I have run spinrite level 2 on the drive no errors. I have run chkdsk /P from the recovery console twice. The first time chkdsk did find errors. All boot options on the boot screen fail. (Safe mode and last know good config fail)

The last driver on the screen before BSOD is mup.sys.

What is the next step to trouble shoot the problem?


How to troubleshoot a Stop 0x0000007E error in Windows XP.

Recovering from a mup.sys boot hang on windows 2000 or XP.


This doesn't really help solve the problem, but it's important to note that the last driver displayed on the screen isn't the cause of the problem - it's the next in line to be loaded. In my case, this was a video card driver, but if you aren't able to boot in Safe mode of VGA mode, that's probably not the case.


Causes of 7E, freezing at mup.sys and getting past it

I have been able to get past the 7E error, but have not yet solved the mystery of how to fix it 100%, or what is causing it in the first place. In this particular case I know it ws not a hardware failure. Dertails follow:

I am in my second attempt to figure out what is causing this. Rebooting continually. Funny thing is, I think I remember safe mode coming up once or twice but never again.

In the first instance time was essential so I installed a new HD (dis-connected the old one -- important so that XP does not try and install a dual boot syatem) Re-installed XP and everything was fine.

then attached 2nd drive and you could get the data off of it.

As for your questions under Recovery mode. The documentation is weak.

CHKDSK /R (implies /p) will check the disk to see if it is readable. IF it finds a corrupt file, I believe it will then attempt to restore it from the CD. I renamed (deleted) a system file and it did not re-install it. Therefore, if a file was infected/ not what it originally was, the CHKDSK under Repair is not going to fix it.

As for access to areas on the disk: MS didn't want to make a tool that could easily bypass their windows secrity. You can write to the hard disk -- in \windows and a few other directories. You can not get to user data, you can not write to ANY external device ( like in make off with data via recovery console) (hint: you can boot some small versions of Linux that have NTFS support and read away -- sometimes worthwhile if you really want to get that data off the drive before messing it it.

Your trying to access areas that MS doesn't want you into is the access denied response.

Now, I would really like to know what is causing these 7E errors as no one has pinned it down. In this partiular case (mine as well as some others) It is crashing after showing MUP.SYS being loaded in safe mode. It appears that windows puts the name up AFTER it has loaded. Simple: I renamed it and it still crashed but the name was not up.

It looks like the death is going from real to protected mode -- the GUI is supposed to start loading. You can get a detailed log with a CD that has Recovery on it ( I found several that didn't ) Hint: You can dowload the floppies for SP2 and it will do it; there are no SP3 floppies, and the burn SP3 CD from Microsoft didn't have recovery on it -- might not have even been bootable. sorry for the tangent.

Boot the emergency CD. Goto c:\windows and rename NTBTLOG.LOG (hope I got that right) this is where windows logs bootup info. You might want to compare where it is stopping now vs where is went to before. the file appends so it can get big. Now you will have an empty (null file) reboot and choose BOOT WITH LOGGING as an option. Now you can choose safe mode or regular. Since I think our goal is to get up in safe mode and work from there choose that. It will crash again, have the CD loaded and go back into Repair console.

Unfortunately, because MS will not allow you to write data out to anything from here you will only be able to view the file, but go back into C:\windows and read the file contents. You will now know how far you got. What that means and why I am not far enough along at this time to tell, or that it will even be the same issue.

CRAZY OUTCOME: windows now boots regular and safe mode but says that I windows is not registered. I cured the STOP 7E error. How? Good question with partial answers. 1) I got a new MB similar to the one I had ( Acer - won't ever buy again: they have gone so far downhill -- just look at the brand names they have consolidated. The manual doesn't even show pin 1 on the IDE connector, no online support. I'm not sure what I would have gotten under warranty but without it, all they said was it was not under warranty and to send it in for $200 and they would replace the MB - not that that would do any good. I ran their supplied BIOS flash and the MB was freezing at verifying DMI Pool.... and would not go further. Couldn't get an answer of even if the BIOS flashed OK -- ie would the checksum initial check fail if it was wrong, no BIOS recovery function, etc. So for $39 after rebate I bought a nice Gigabyte MB; same basic chip set, different video ( the CPU is an AMD 64 X2 athalon 4200+) with dual BIOS chips ( current and fallback on board as well as recovery) put everything back together, and whalla !! same 7E Error. I'm pretty sure that rules out a hardware issue on the other MB causing the 7E error, or that a hardware failure in general is responsible.

So, back to Recovery CD. this time I let it FIXBOOT and DISKPART.

DISKPART is what was probably interesting. It showed 3 partitions.
1 - EISA diagnostics ?? Something from Acer - I think you can boot this and test your MB and other functions 2 - Windows partition 3 - data partition ( Acer split drive in half) 4 - un-allocated space 4500Meg free

I let it make a bootable (or let them be listed as options) So I ended up with 3 boot partition options

I ran FIXBOOT (but that seems to only tell it which partition to default to) -

FIXMBR says that the record is non-standard and data may be lost if re-written. I'm afraid to run it at this time. Might be whats needed.


I kept trying the 3 new boot options the regular "Windows-XP" still crashes and reboots as before but Partition1 BOOTS! I get drive C&D what was there before.
It sees my created User names - so I know its reading my old data It will come up in either safe mode or regualr mode - my screen resolution is low but thats most likely due to it not having the correct drivers for the NEW MB.

BUT GET THIS: It says I am running a non-activated version of Windows. In regular mode it will only allow me to try to activate -- which it can't do because the ethernet drivers need updating, or by calling MS. I am holding off on this while I hope to get more data on the 7E Error. Now its been activated and running for 2 years now. Same lost activation info for office as well.

In safe mode, It lets me in and puts a big banner on the bottom that windows needs activating. Probably something triggering that its 2 years old and it should not be running without it a this point -- past the 30 days they give you.

What I have yet to figure out is how the 3 different boot partitions records differ and how one can come up with a not activated and yet run screen, while the other blue screens -- obviously somehow running fro the same physical partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.