1

Assuming this user never logged on to this PC before, it will take 1-2 minutes before desktop shows up. All subsequent logins are near instant. Another PC - same problem. Problem repeats if local profile for this user is deleted. Is there any remedy?

Additional information:

  • We do not have any specific group policy settings, except for 4 options dealing with Windows update (I think it's 4 of them that we are using).
  • All computers are members of the domain, users are logging in using a domain account.
  • Profiles need to be deleted in the rare case they become corrupted. Don't ask me why - ask Microsoft.
5
  • 3
    Don't delete the local profiles? Commented Aug 30, 2012 at 18:43
  • You don't provide nearly enough information to answer this, is the PC a member of a domain, what sorts of group policies are being applied, etc...
    – HostBits
    Commented Aug 30, 2012 at 18:44
  • 4
    So, assuming that "near instant" isn't going to happen for the first login, as that's only happening on subsequent logins because of the work being done in the "1-2 minutes" of the first login, what time would you consider acceptable for a first login, how have you arrived at that and what troubleshooting have you done already to find delays yourself? No there isn't a "HKEY_LOCAL_MACHINE\MAKE_COMPUTER_LOG_IN_QUICKER" registry key that we all know about and you don't.
    – Rob Moir
    Commented Aug 30, 2012 at 19:00
  • @ErnieTheGeek: replacement of the PC usually deletes all the local accounts. With many number of PCs and frequent change of hardware, this issue is inevitable. Cheekaleak: sorry about that, I updated the question with new information. DJ Pon3: thanks for your positive attitude and enormous help in figuring this out. You really made my day. Commented Aug 30, 2012 at 22:14
  • 1
    i know this subject has been beat to death but the issue I’m having seems to be a little different and I’m not coming up with any fixes. Win7x64 on Server 2008 domain. I’ve created a custom image and applied to many Dell 760’s, 780’s and a couple others for testing. The 780’s are equipped with an ssd and 4gb ram. The 760’s and other pc’s no ssd and 4gb. Commented yesterday

2 Answers 2

11

Upon the first login, the profile must be created. This takes longer than subsequent logins. Also, user GPOs must be downloaded and applied from the DCs. The length of this creation and GPO application process can take some time depending on GPO and local policy, but 1-2 minutes doesn't sound unreasonable. I'd hardly consider this a "slow" login.

7
  • Assume there is nearly nothing to be applied, as we don't have any specific complex GPO, except for 4 options regarding windows update policy. I still can't believe why it would take that long. And it's definitely annoying on i7-2600 and 8-16GB of memory. Commented Aug 30, 2012 at 22:20
  • What you're describing is completely normal. There's also user settings in the default domain policy that are applied, and those few GPOs that are applied still take some time. Seriously, 1-2 minutes is not a long time, especially when it's only during the first login.
    – MDMarra
    Commented Aug 30, 2012 at 22:32
  • 1-2 minutes can become 5 when the collegue says "yeah, it's taking long, so I'll go grab a coffee", somebody stops them for a talk on the way back - it becomes 15 or half an hour - you decide to come back later etc. - that's how it can make a difference. Why would even first login matter? Imagine another person says "Hmm, it does not work under your account, let's try mine? Hmm, still does not work, let's try my another one" (with higher privileges). Even if it's only 1 minute. What if you had 100 PCs and 100 people? That's 10000 minutes, or 20 x 8-hour man-days. Then you start counting. Commented Aug 30, 2012 at 23:31
  • 4
    First of all, this is only during the first logon, not every time. If the only time you waste man hours in a day is on a 1 min logon, then you've got the most efficient company ever. Don't worry about it. It's one minute. Second of all, think of all of the lost man hours if you weren't centrally managing everything. That's the trade off. I'm sorry that you don't like the answer, but it's completely normal. If you have an issue with it, you'll need to contact Microsoft and request that they speed up new profile creation. It's literally a non-issue for everyone else on the planet.
    – MDMarra
    Commented Aug 30, 2012 at 23:48
  • 2
    For what it's worth, Win8 has even faster profile load times than Win7. Too bad it's got that hideous interface, they did make quite a few improvements too.
    – Chris S
    Commented Aug 31, 2012 at 16:47
-3

1-2 minues is way too long if nothing much happens (massive GPOs etc.). Unfortunately there is no easy way to troubleshoot such slow logons - the delay might be network-related, or something completely different. What you can do:

  • Trace what happens on the machine while logging on with Sysinternals Process Monitor
  • Trace what happens on the network (use whatever network tracing tool is available to you, Microsoft Network Monitor will do just fine)
3
  • This would be interesting to try. Is there anything specific I am looking for with Process Monitor? With no filter I expect several hundred thousand of events logged when I am back, and most of those do not make much sense to me. Commented Aug 30, 2012 at 23:22
  • 1
    Did you read the question? The 1-2 min is only during the first logon during profile creation. It's not like it's every time. In fact, the op says that it's almost instant after the initial logon.
    – MDMarra
    Commented Aug 30, 2012 at 23:47
  • If you don't know something is impossible, you have a much higher chance of succeeding in it. I would rather attempt to troubleshoot and fail to find a problem, than admit I did not even try it. Commented Aug 31, 2012 at 0:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .